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Creating visibility layers

Selecting one geometry part we go to the bottom right part of the screen where a Display tab 
exists.On it's right there are four icons and the rightmost is the one that creates a layer and adds to it  
the selected objects from the scene.Now we can see a layer named layer1.Double clicking on it we 
can rename it(ie right_arm_geometry) and add a colour so that all members of the layer are viewed 
with that colour in the viewport.For layer names I suggest lowercase with underscores( _ ) instead 
of  spaces  and  something  different  from  the  exact  name  of  a  node  that  can  be  found  in  the 
Outliner.You could always concatenate "_layer" at the end of the name you want.
There are three modes the visibility layers work with.One is the plain visible-invisible controled by 
the left box and has a V symbol when visible.The other two are working on top of the visible-
invisible mode to extend it and are controlled by the second box.First Template mode(T in the 
second  box)  and  Reference(R  in  the  second  box).Both  modes  make  the  layer's  members 
unselectable  and  unmodifiable  but  the  difference  is  in  snapping(see  Appendix  B)  to  them.In 
Template mode you cannot snap to a member object while in Reference mode you can.

Snapping

Snapping is the feature that enables us to change the position of an object to the position of 
another.If for example we have two joints and we want to move one joint to be in the exact same 
position in the world as the other we can just go into Move mode and while pressing V drag the  
wheel button slightly around the intended position and you can see the object "snapping" on to the 
other object.It's a very delicate feature so always check from various angles to confirm it's really 
snapped.Also you can snap in specific axes too instead of all three at once.If you want to move a ie  
a joint to have the same translate X value you can just go to Move mode,select the X axis move 
arrow/handle and while pressing V snap to the desired object.

Copy UVs from one mesh to an identical one in the same scene

Go into Polygons Mode in order to use the Mesh menu.Select the mesh with the correct 
UVs,then select the one with the corrupt/wrong UVs.Go to Mesh->Transfer Attributes[].Set vertex 
position  and  vertex  normals  to  Off,UV  sets  and  color  sets  to  All  and  Sample  space  to 
Component.Leave the  rest  as  is.Provided you  have  assigned the  correct  materials  to  the  target 
meshes,you will see the intended result.

How to use MEL scripts

There are three ways to use MEL in Maya.First of all,through the MEL command box on the 
lower left part of Maya,though usually it is used for one or two commands.Then there is the Script 
Editor where you can see the MEL commands that are executed while Maya runs,commands that 
are the equivalent of the tasks you perform using the GUI.You can also use the lower part of the 
Editor to write MEL scripts and after selecting the lines you want to run,click on the play icon on 
the top.At last,we have MEL script files saved somewhere in the disk as command.mel.It is most 



convenient to name the file exactly like the function name and declaring the function as a global 
one.When  Maya  starts,it  finds  all  scripts  by looking  in  certain  folders  and  if  there  are  global 
functions,Maya will have them indexed and they can be called just by entering the name of the 
function followed by arguments,if there are any, and a semicolon(`;`).If you change the script file 
while Maya is open,Maya won't see the difference and will still use the old version.One way to 
avoid this is to source the script after changing it.You can source a script by clicking on the source 
script icon and selecting the said script when the browser pops up.

The structure of a MEL script is :
global proc command(){
....
}
i)global for it's scope,meaning we can use it wherever we want.
ii)proc to define it's a process
iii)command is the name of  the function
iv)inside the parantheses we have to put the arguments

(MEL scripts)Circle Control,Cube Control,Joint Curve Control

First we have the typical NURBS Circle control:
/*

-ch:Turn the construction history on or off
-o:Create the result, or just the dependency node(on and off respectively)
-nr:The normal of the plane in which the circle will lie(0 1 0 used since the 

normal is the vertical vector on the Y axis)
-r:The radius of the circle(
-s:The number of sections determines the resolution of the circle.Used only if 

useTolerance is false;

*/
string $name="_input the name you want the new circle to have_";
int $sections=number of sections you want the circle to have,means vertices too.
circle -ch on -o on -nr 0 1 0 -r 1 -s $sections ;
CenterPivot;
rename "nurbsCircle1" $name;

Then we have the Cube Control that came from CV Curves:
/*

-d:The  degree  of  the  new  curve.  Default  is  3.  Note  that  you  need  (degree+1)  curve  
points to create a visible curve span. eg. you must place 4 points for a degree 3 curve. 
-p:The  x,  y,  z  position  of  a  point.  "linear"  means  that  this  flag  can  take  values  with  
units. 
-k:A knot value in a knot vector. One flag per knot value. There must be (numberOfPoints + 

degree - 1) knots and the knot vector must be non-decreasing. 
*/
curve -d 1 -p 3.537353 2.190347 0.5 -p 3.537353 2.190347 -0.5 -p 4.537353 2.190347 -0.5 -p 
4.537353 2.190347 0.5 -p 3.537353 2.190347 0.5 -p 4.537353 2.190347 0.5 -p 4.537353 1.190347 
0.5 -p 3.537353 1.190347 0.5 -p 3.537353 2.190347 0.5 -p 3.537353 1.190347 0.5 -p 3.537353 
1.190347 -0.5 -p 3.537353 2.190347 -0.5 -p 3.537353 1.190347 -0.5 -p 4.537353 1.190347 -0.5 -p 
4.537353 2.190347 -0.5 -p 4.537353 1.190347 -0.5 -p 4.537353 1.190347 0.5 -k 0 -k 1 -k 2 -k 3 -k 



4 -k 5 -k 6 -k 7 -k 8 -k 9 -k 10 -k 11 -k 12 -k 13 -k 14 -k 15 -k 16 ;
select -r curve1;
CenterPivot;
rename "curve1" $name;

And last but not least a Joint Curve Control:
//Create curves
string $cv1[] = `circle -c 0 0 0 -nr 0 1 0 -sw 360 -r 1 -d 3 -ut 0 -ch 1`;
string $cv2[] = `circle -c 0 0 0 -nr 0 1 0 -sw 360 -r 1 -d 3 -ut 0 -ch 1`;
string $cv3[] = `circle -c 0 0 0 -nr 0 1 0 -sw 360 -r 1 -d 3 -ut 0 -ch 1`;
//Rotate curves to look like a joint
rotate -r -os 90 0 0 $cv2[0];
rotate -r -os 0 0 90 $cv3[0];
//Freeze the rotated curves
select $cv2[0];
 select -add $cv3[0];
makeIdentity -apply 1 -t 1 -r 1 -s 1 ;
//Parent shapes of curves 2 and 3 to curve 1
string $relCrv2[] = `listRelatives -shapes $cv2[0]`;
string $relCrv3[] = `listRelatives -shapes $cv3[0]`;
parent -r -shape $relCrv2[0] $cv1[0];
parent -r -shape $relCrv3[0] $cv1[0];
//Delete the trns node of curves 2 and 3
select $cv2[0]; select -add $cv3[0]; doDelete;
//Rename the joint curve
string $rnmCrv = `rename $cv1[0] $name`;
//Delete history on joint curve
select $rnmCrv; 
DeleteHistory;

(MEL scripts)Match Transforms Tool, Remove Non Zero Rotations, 
Remove Namespaces

matchTransformsTool
After selecting the object we want to move and then the object whose position we want to 

give to the first we run the following MEL script:
string $selObj[] = `ls -sl`;
string $ptCsObj[] = `parentConstraint $selObj[1] $selObj[0]`;
string $findPtCns[] = `listRelatives -type parentConstraint $selObj[0]`;
select $findPtCns; doDelete;
select $selObj[1];

RemoveNonZeroRotations

It's  a very frequent problem when working on the rig and if  you are creating stuff  and 
deleting them thus affecting the joints it's pretty much unavoidable albeit unpredictable as far as 
when it's going to happen.So there is a way to remove Non-Zero-Rotations from all joints as long as 
there aren't any ikHandles or Controls on them.Considering the place it's going to be needed though 
you might have to redo the ikHandles but it's the easiest part so you don't have to be disappointed.



Here is a MEL script I made which traverses the joint chain and zeroes every joint's rotation 
attributes:

string $rootjoint = "(fill in the root joint's name here,in this case HumanoidRoot)";
select -r $rootjoint;
string $joints[] = `ls -sl -dag`;
for($node in $joints){

setAttr ($node + ".rotateX") 0;
setAttr ($node + ".rotateY") 0;
setAttr ($node + ".rotateZ") 0;

}

RemoveNamespaces

// Get All Nodes In Scene  
    string $allNodes[] = `ls` ;  
      
    // Loop Through Them  
    for($node in $allNodes) {  
      
     // Tokenize And Rename  
     string $buffer[] ;  
     tokenize $node ":" $buffer ;  
     string $newName = $buffer[size($buffer)-1] ;  
     catch(`rename $node $newName`) ;  
      
    }  

Fixing UV maps and textures

Whenever there are overlapping UV maps we cannot use weight maps. Also there is a 
potential problem when exporting to COLLADA.To fix them,we must talk a bit about 
materials.Materials are a combination of textures and shading.It defines a surface as being human 
skin or concrete.Materials are represented with four nodes in the Outliner.In our case,phongXX(XX 
is a number),phongXXF,phongXXP2D and phongXXSG(usually but it might have a different 
name).The first file represents the type of material,in this case phong.
The second file has information about the 2D texture file,hence it's F suffix.The next one has 
settings for the placement of the 2D texture file.Last but not least we have the shading engine.We 
need to gather information about the materials and the texture coordinates before we try moving the 
UVs themselves.

Basically we have to create the materials anew.To do that though,we need to know 
everything about the existing ones.Instead of writing the settings down we will work in a temporary 
copy of the file containing the geometry.The only information we need to note is the texture files of 
the materials.Sometimes there might be two materials on the same mesh. That is very 
unreliable,especially when we're trying to export the result in COLLADA.The exporter plugin,ever 
capricious,will cringe at the site of multiple materials on a single mesh.In fact,in earlier tries to 
export in this thesis,the plugin failed to export all three materials Ryan's face mesh initially had and 
as a result the face mesh disappeared.In order to rectify the situation,we must create new textures 
and move the UVs in place.We need to put the textures from the two materials(the ones that contain 
the main textures) in one texture.The safest way is to put one texture immediately below the 



other.Going into an image editing application,we check on the sizes of both images and add up on 
height.For example if we have two images of 1024x768,the resulting texture would be 1024x1536.

Now that we have the new texture,in Maya,we delete both phong materials containing the 
two textures we put together,taking care we didn't leave any of the four nodes we mentioned earlier 
that form a material.Let's say the mesh that contained the two materials was the face mesh to make 
the explanation easier.We select the face mesh,right click on the mesh and click on Assign New 
Material.There we select phong since both materials we deleted were phongs.The attribute editor 
will appear on our right and there will be two tabs,phongXX and phongXXSG.So we already have 
the shading group node.In the phongXX tab,click on the checkered icon at the right of the Color 
slider and select File to declare that this material will get it's texture from a file.Two new nodes will 
be created,file1 and place2dTexture1.Rename them to phongXXF and phongXXP2D 
respectively.Back at the phongXXF tab,click on the folder icon at the right of the Image Name 
field.Browse and select the new texture we made earlier.At first the texture will look very weird on 
top of Ryan's face mesh.The UVs are still overlapping so they are grabbing wrong parts of the new 
texture to put on the mesh.

It's time to open up the Texture Editor(Window->UV Texture Editor).Make sure you select 
the face mesh before opening the editor or if you don't then minimize the editor,select the face 
mesh,maximize the editor and unzoom if need be.You can see the UVs(white wireframe shapes) 
and the new texture below.You will notice that the UVs' size,and their position as well,is not right 
.Fortunately for us we can both scale and move the UVs.To grab a UV we must be at UV selection 
mode.Click anywhere in the editor and hold right click and select UV.Now we can select points on 
the UVs.To select a whole shape we must select a point from it and go to Select->Shell.If the UV 
shape consists of multiple smaller shapes,we need only select one point from each of them and go to 
Select->Shell again and that will give us the whole UV shape we want.Now we can use the move 
tool or the scale tool from the default Maya interface(do not search for them in the texture editor) 
and either move or scale the UV.Be very careful in the selection of points in order to get only the 
UV you need when trying to select from overlapping UVs.Then scale them appropriately and move 
them on top of the texture they ought to be.You might have to experiment a bit with the position and 
scale until you are satisfied that the result is perfect.
After  we have successfully created all  materials  and textures  it's  time to modify the  materials' 
settings.We will use the values in the old version,the original geometry file.That's about it.

Cleaning up the Rig

Professionals,after having rigged and skinned the character,clean up their rigs.That means 
locking and hiding attributes you don't want the animator to see or accidentally use.We talked about  
the  three  states  an  attibute  can  be  in,Keyable,Non-keyable  and Non-keyable  Displayable.When 
cleaning the rig,we set the unused attributes in Non-keyable mode.If there are any attributes,we 
think the animator  would benefit  from knowing their  values,we must  set  them to Non-keyable 
Displayable.Basically  we  go  over  most  transformable  objects,be  it  joints,  controls,  ikHandles, 
anything really, and hide or lock  some of their attributes.To hide means to set an attribute as Non-
keyable,while  to  lock  means  to  set  the  attribute  as  Non-keyable  Displayable.To  hide  an 
attribute,select it,right click on it and click on Lock and Hide Selected.To lock an attribute,do the 
same but click on Lock Selected.



Installing OpenCOLLADA importer/exporter plugin and enabling it

Download  the  plugin  here.Install  it  the  usual  way  and  after  the  installation  has 
finished,launch Maya.In Maya go to Window->Settings/Preferences->Plug-in Manager.Search for 
ColladaMaya and check all boxes to it's right and hit  Refresh and then Close.Restart Maya and 
check that in the Export or Import feature there is an OpenCOLLADA entry under Files of type.

https://github.com/KhronosGroup/OpenCOLLADA/wiki/OpenCOLLADA-Tools
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