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ABSTRACT

In the world of 3D graphics there are a number of different software applications and 
tools one can use.But like everything else in the world,there are tools better suited for some 
areas  while  not  so  much  for  others.One  tool  might  be  better  in  modelling,another  in 
lighting,another in texturing and the list goes on.However all those tools have their own file 
formats which makes the use of different tools,in order to maximize the potential of the assets 
being made or  to  make the  artist's  life  easier,an  impossible  task.Of course this  has  been 
forseen  and  some  attemps  to  rectify  this  have  been  made.But  what  we  need  is  a  more 
universal file format and compatibility with pretty much every tool out there.One such format 
is  COLLADA.COLLADA is as Wikipedia states "a  COLLAborative  Design  Activity for 
establishing  an  interchange  file  format for  interactive  3D applications.It  defines  an  open 
standard  XML  schema  for  exchanging  digital  assets  among  various  graphics  software 
applications  that  might  otherwise  store  their  assets  in  incompatible  file  formats".[1]The 
reason for this paper is:does this universal format really work?
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Introduction and Overview

We need a common file format in order to use a variety of graphics applications and 
utilize their  full  potential.Like we said previously each application has it's  own pros and 
cons.As a result,one wants to be able to use the pros of every application out there to make 
his job better in terms of quality and possibly with the least ammount of work.One possible 
solution is the COLLADA format.[2]This dissertation is about testing how well COLLADA 
does  that.We  want  to  know  if  this  format  can  retain  all  of  the  information  we 
need,i.e.information  about  the  geometry  like  it's  vertices  and  their  positions,  the  joint 
hierarchy,textures,UV maps,skin weights and so on.

In this project we will use an already made 3D model which will be fully textured for 
speed.I don't have the knowledge or ability to create a 3D model and especially one of high 
detail and polygon count in the time budget of this dissertation.The model we will use is  
Ryan from Google's 3D model archive.After setting up Ryan,we will animate him,export him 
using a COLLADA exporter plugin and import him in OpenScenegraph to check if any kind 
of information is lost.Also we chose to use Autodesk's Maya for the rigging and skinning 
since it's prominent as a software application.

One word of advice to the beginners,start off with a model that has a low polygon 
count.The process of rigging and skinning a character to be animation-ready is not difficult 
but at first can be troublesome.Problems will pop up from places you don't expect them to  
which can be accounted to lack of experience.I found that the hard way even though I didn't 
exactly know what to expect.Bottomline,start off with easier 3D models and work your way 
up.The point where you will understand the meaning of this advice is skinning and especially 
getting the model to deform naturally when animating.It is a rather difficult task when one 
does not have experience.

Be sure to check the Additional Instructions document that goes along with this report,
as  it  contains  several  excerpts  describing  how to  use certain  features  in  Maya and other 
miscellaneous and helpful instructions.



State-of-the-art

In recent years,we've seen a rise in the demand for 3D graphics and a demand for 
increasingly  realistic  representation  of  humanoids.We've  seen  improvements  in  all 
aspects.The  use  of  3D  vectors  for  translatios  and  quaternions  and  euler  angles  for 
rotations.The use of interconnected vertices to form meshes (3D geometric objects) and bone 
segments and links (also referred to as joints) to form a skeleton and the invention of skinning 
in order to connect the mesh to the movement of those bones.[3] Jacka et  al[4] describe 
Skeletal-Subspace  Deformation,the  simplest  and most  widely used  and also  called  linear 
Linear Blend Skinning,Enveloping,Smooth Skinning and Vertex Blending(also explained in 
[5]).Through  this  framework  the  new  vertex  ,for  all  of  the  mesh's  vertices,location  is 
calculated by linearly combining the weighted positions proposed by each animated bone that 
affects the vertex.But SSD has a well known shortcoming,as in volume loss due to extreme 
rotation in joints.To address this problem many approaches were published,such as Animation 
Space  Skinning,Multi-Weight  Enveloping  etc.Most  of  them  required  either  increased 
complexity,more bones or more weights.Then came Dual Quaternion Skinning which was 
very efficient and solved the the candy-wrapper problem(as the volume loss in SSD was 
referred to).All of the above methods,though,are based on the idea that a skeletal structure 
drives  the  deformations.Scientists  have  always  had a  knack to  explore  other  possibilities 
too.A result of that habbit was the use of blend shape-based approaches.Examples of blend 
shape-based  approaches  include  Interpolation  between  Models,Interpolation  between 
Images,Blendshape Animation from Model Segmentation and Reanimating Faces and Images 
using Morphable Models(basic blendshapes)[3].We are mainly interested in the last method 
since shape blending apart from the face is somewhat impractical.The notion is that we can 
reproduce any kind of facial expression by blending between existing model samples with 
facial expressions.



Methodology

1. Geometry
Before delving deeper into the process of rigging Ryan we need to make sure the 

geometry is compatible with the tasks we'll perform.First off,the number of geometry parts 
our model consists of,mustn't be too high.The original version of Ryan's geometry consisted 
of  73  parts.That  number  is  an  overkill  when  skinning  which  we  will  talk  about  much 
later.Perhaps a well trained or professional rigger might have succeeded at it but considering 
the skill of the readers we have to go with an easier,more accessible and in my opinion more 
solid approach.The coloured images below show the original version's parts.

Personally  the  approach  I  prefer  is  the  approach  game  artists/riggers  use.The  3D 
model gets cut or merged in 6 basic pieces:head,torso,left arm,right arm,left leg and right 
leg.Actually my approach had one more,Accessories,the reason being that the belt and some 
other parts of the pants Ryan wears are difficult to skin with the rest of his legs.Also I merged 
the  two legs  together  since  it's  pretty easy to  skin  them.Setting  aside  the  differences,the 
reason why this is a good approach is because it's highly fixable and reliable.



When you have different parts of geometry you can fix just the one while the rest are 
left untouched.Another advantage is that no joints are connected and able to influence an 
unrelated geometry part.If you follow the standard approach,a leg joint might end up having 
some  influence  over  arm  vertices  if  not  carefully  checked  when  performing  fixes.With 
different  geometry  parts  you  bind  specific  joints  to  the  part  and  not  the  whole  joint 
hierarchy.Thus finished parts remain that way.You might end up importing ,fixing, binding 
etc but at least you can be certain it won't affect whatever is finished,whatever you want to 
leave untouched.Of course there is some extra work needed at the "seams" when skinning,the 
places  where adjoining parts  meet so that  they seem as one and not  apart.For a  detailed 
description of how you can merge and combine geometry parts see Appendix section A.

There is one more part about UV maps that could be done now but it is better left for 
later on when you will have a better understanding of things.

At this point I would recommend you create a visibility layer for each of the geometry 
parts(See Additional  Instructions)  and in  the end save this  as Ryan_Geometry.ma(the ma 
extension  is  the  Maya  Ascii  which  is  the  uncompressed  format,we will  use  it  in  all  our 
files) .If you decide to make more versions of the geometry find a naming system to be able  
to recognise them apart.It is a good practice to have components of your work in different 
files and have many versions of your work so that fixing gets easier as you progress.Even if 
you are at the end and decide something needs to be fixed you just have to import every thing 
you will need in one scene and connect them.You can also import the character you decided 
was  wrong  and  use  it  as  reference  for  the  fixes  and  possibly  to  copy  information 
from(weights,controls etc).

2. Rigging

Rigging is the process of placing joints and creating a skeleton for the 3D model by 
parenting those joints in a hierarchy with one joint acting as the root.The joint skeleton is to 
the model what our skeleton is to our body.It drives our muscle and organs' system when 
transforms occur to it.However it is not just positioning joints.As it is we could animate but it  
would be too troublesome.There are so many features we can use to make our lives,and the 
animator's,easier.We can create  ikHandles  and Controls  for the skeleton as  well  as apply 
constraints  to  make  the  model  move naturally.To explain  a  bit,when we move the  wrist 
towards our body,the elbow moves too so ikHandles are there to control the transforms of a 
number  of  adjacent  joints  and  emulate  the  transforms  that  happen  in  a  real  skeletal 
structure.Controls are basic geometry like a polygon cube for example that we connect to the 
ikHandle so that it controls the transforms of the ikHandle.We don't really want to directly 
transform  the  ikHandle,joint  or  anything  of  the  sort.That's  why  we  use  controls,it's  the 
interface an animator needs to do his part  of the process.Constraints  are there to help us 
connect things and create rules of behaviour in the process.For example we can do a point 
constraint between two things(a Driver and a Driven) and what that does is,when the Driver 
moves the constraint makes sure to move the Driven an equal ammount as the Driver.

2.1-Skeleton
In the introduction we said we are going to use the H-anim Standard[6].The H-anim 

Standard has it's own joint list which states how many and what joints must be used and you  
can see them in the following Tables.As you can see there are tables with the names of the 
joints for the body,the hands and the face.You must follow the naming of the joints and the 



parenting very strictly because one of the reasons behind this Standard is that whoever has 
animation data from one H-anim compliant character can use them to animate any H-anim 
compliant  character.For a  description on how to position joints  and create  a skeleton see 
Appendix  section B.We will also make a few modifications to the H-anim Standard ,without 
straying from the instructions  about  modifications  given  here in  Section  4.9.6-Additional 
Joint and Segment objects, in the Leg joints to be able to make a Reverse Foot Lock.

Now let's see the hierarchy we chose and also some pictures of the result:

http://h-anim.org/Specifications/H-Anim200x/ISO_IEC_FCD_19774/concepts.html




Face Joints

These are images taken from Maya's Outliner so you can see the hierarchy clearly by 
following the lines.

Before you start creating the skeleton,we need to stress the importance of two things 
as far as the skeleton is concerned.Joint Positioning and joint Orientation both need to be 
correct for the rig to work.Let's give one example of bad exercise of each of the two.Placing 
the hip joint slightly lower than it's ideal point might give us good results at first while testing 
the rig,it's handles etc but the problem will show when skinning when it will be difficult and 
even impossible to get natural deformations for the gluteal muscles.For example the lower 
part of those muscles that connects to the upper leg even when influenced with the max value 
isn't  deforming right.The second example  is  about  joint  orientation,let's  imagine  the  arm 
joints for a bit when Ryan is in the T pose,we select the elbow joint and rotate using the 
horizontal circle of rotation or plane if you like.We expect the fore arm and the hand to rotate 
in such a way that they point forward,but since the orientation of the joints in the arm is not 
correct  and  consistent  for  that  matter  instead  the  forearm and hand  rotate  upwards.Joint 
Orientation basically governs how each joint rotates and translates in the world.The local 
axes of an object ,that are used when moving or rotating, in Maya are set using the orientation 
of the object.When the orientation of the joints ,i.e. in the arm, are inconsistent each of these 
joints will have different local axes.



When the orientation of the joints in i.e. the arm are inconsistent each of these joints 
will have different local axes.While both of these problems are found during skinning,wrong 
joint positioning is easier to fix than wrong orientation.The reason is that while we need to 
delete ikHandles,Constraints and unparenting to fix the position, it's just a couple of joints in 
the most cases.However with joint orientation it's usually multiplem,if not all, and that means 
undoing most of the work already done.It's extremely important to get them right from the 
start to minimize ,as much as possible, the need to undo work for fixes.That said the way to 
work is,first place the joints for the whole body and afterwards orient them all using one 
orientation scheme that eliminates as much as possible the Gimbal lock problem.One quick 
word about the Gimbal Lock problem.Basically one degree of rotation/freedom of the three is 
lost.Where before you could rotate in three planes,now you can only do that in two of the 
planes  since  two  of  them are  aligned.That  happens  because  the  planes  are  set  up  in  a 
hierarchy so that a plane affects it's child plane and is affected by it's parent plane.So rotating 
on the top most affects the second plane which in turn affects the last one.Rotating the last 
one though doesn't do anything other than rotating in that plane.The problem is when ,say we 
have a scheme like XYZ,we rotate on the Y axis so much that the Z plane aligns with the X 
plane.Rotating either in the Z axis or X axis it will appear as the same rotation.The scheme 
that worked for me was YXZ(Maya represents the scheme backwards so it's really ZXY).The 
best approach for whatever model you have would be to place the joints and try out different 
orientation schemes until you find the best.But do not continue until you have or a lot of  
fixing/redoing work awaits you in the next stages of this process.

This is an example of the orientation you would like:

As you can see the Y local axis points to the next bone,the X local axis is vertical to  
the bone direction and the Z local axis points to the side.You might end up using a different 
scheme but in the end we want it to be as consistent as in the example above.



2.2-Sets
This is probably the best time to create Sets for the joints.It really is an optional step 

but I can safely say that it will rid you of the boring moments you will have to select joints in 
your  scene.Sets  are  nodes  that  aid  in  the  mass  selection  of  objects  especially  when  the 
number of objects is high.Since we have to conform to the H-anim Standard which has plenty 
of joints it will be difficult to shift select them every time.If you think otherwise consider that 
the Outliner looks rather bare right now and later on there will be too many things stored in 
the scene and the hierarchy itself will be very crowded.Unfortunately dragging the mouse 
button over the whole skeleton to select everything only selects the root joint.To avoid having 
to expand the hierarchy in the Outliner every time in order to select all joints or try to shift 
select them in the viewport we create Sets.The way to create them is very simple.We just 
select the objects we want to be in the Set(either from the viewport or the Outliner) and go to 
Create->Sets[].We give the Set an appropriate name(be careful to  give a unique name to 
avoid conflicts,consider doing this for everything from here on out) and press Apply and 
Close.In the Outliner we can see the Set node with the name we gave and expanding it we 
can see only those objects we wanted.I suggest you create as many as you can think.But for 
starters one for the body joints(for Ryan this means until the spinal joint from which the neck 
starts),one for the head joints(again for Ryan's case from the joint that the neck starts) and one 
last one with all the joints(body and head) should suffice.We will create some more later on.

Here is a list of the Sets I created on Ryan's case and an example of what a Set  
looks like:



2.3-Kinematics
Now that we have the skeleton we must make it move like a human body.That's what 

Kinematics do.
Kinematics  is the branch of classical mechanics that describes the motion of points, 

bodies (objects) and systems of bodies (groups of objects) without consideration of the causes 
of  motion[7].There  are  two  types  of  Kinematics:Forward  and  Inverse  Kinematics.Both 
describe the motion of an end-effector but they differ in their approach.Really,they are two 
sides of the same coin.Forward Kinematics negotiate the position of the end-effector through 
the  use  of  kinematic  equations  from  the  values  of  the  joints  attributes  while  Inverse 
Kinematics  do  the  opposite,taking  into  account  the  desired  position  of  the  end-effector 
,through the use of kinematic equations,they determine the values for the joints attributes.For 
example we have a robotic arm and the hand or pincer or whatever is placed at the tip is the 
end-effector(or end joint) and there's also a base joint(start joint) and a middle joint.If we use 
Forward Kinematics to animate the arm we will control the joints themselves to create the 
desired position.If we want the arm to pick up a pipe,we will have to rotate the base joint 
forward,rotate  the  middle  joint  downward  so  that  the  end-effector  is  on  top  of  the 
pipe.Whereas if Inverse Kinematics had been used,we would have moved the hand itself on 
top of the pipe and the rest of the joints  would have followed in as much a natural way 
towards  the  pipe  as  possible  and  most  times  it  is  plenty  natural.We  will  use  Inverse 
Kinematics mainly since this project is not about the rigging itself but testing the COLLADA 
format.Professionals tend to use IK in most of the body and a blend between IK/FK in areas 
that the animator wishes greater control,ie the arms.The legs are quite fine with just IK.As far 
as implementation goes in Maya,FK is pretty straightforward,we just rotate the joints and get 
the  result.IK  though  is  handled  differently.Interestingly  the  word  "handled"  is  the  key 
word.Maya has a feature called ikHandle.To understand what the ikHandle is ,try to imagine 
a  line  from a  starting  point  to  an  end-effector.This  line  starts  from a  joint  and  ends  in 
another.Basically you control the end-effector and through the kinematic equations the values 
for the attributes of the joints ,along the joint chain(from the starting joint to the end-effector 
joint), are being calculated.If we make an ikHandle on the robotic arm it will start from the 
base joint,through the middle joint and have the hand/pincer joint as the end-effector.Moving 
the end-effector around calculates the Translate and Rotate attributes for the middle and base 
joint in addition to the end-effector's own attributes.

This is what an ikHandle looks like(taken from Maya Help Files):



An example of Inverse Kinematics:

An example of Forward Kinematics:

Just like Kinematics,ikHandles have four types.We have the Rotate Plane,the Single 
Chain,Spline and Human IK.In actuality,the difference in the first two types is not in the 



handles themselves but in the mathematical algorithm behind them ,aka the IK Solver.The 
difference between a Single Chain ikHandle and a Rotate Plane ikHandle is that the Single 
Chain ikHandle’s end effector tries to reach the position and the orientation of its ikHandle, 
whereas  the  Rotate  Plane  ikHandle’s  end  effector  only  tries  to  reach  the  position  of  its 
ikHandle. Since the Rotate Plane ikHandle’s end effector only tries to reach the position of its 
handle, the resulting joint rotations are more predictable.[8]

Spline ikHandles are a bit different.They let you pose a joint chain using a NURBS 
curve. When you manipulate the curve, the handle’s spline IK solver rotates the joints in the 
chain accordingly. You can use spline IK to pose and animate long, sinuous joint chains such 
as those for a tail, a tentacle, a snake and so on.[8]It can also be used in posing and animating 
a spine.

Spline IK example(taken from Maya Help Files):

Human IK is totally different.It's a more automated way of making ikHandles and is 
only  used  by  characters  that  have  been  characterised.  Basically  you  map  templated 
characterisations  of  body parts(labels)  on  your  skeleton  to  be  able  to  create  an  Human 
ikHandle.In this project though we won't be needing this.

Full Body IK example(taken from Maya Help Files) where numbers define labels:



Afterall you can't use a Human ikHandle with the rest.It's either Human ikHandle or 
some/all of the rest.

Here is an image of the result:

For Ryan's ikHandles,see Appendix section C.

2.4-Controls
After having created the ikHandles we will have them attached to controls so that we 

have a more solid system of moving those handles.The reason being,ikHandles cannot be 
returned to their initial position by zeroing out the attributes.It's easier for us to have the 
controls know the offsets and initial position and gain the ability to zero out values to get to 
the initial position.

The way to create controls is somewhat standard.Go to Create submenu and choose 
either NURBS or Polygon and then one of the primitives.Edit their vertices to customise the 
shape and if need be,change it's pivot point.Freeze the control's transformations to ensure that 
zeroing out the attributes after having transformed it will return it to the origin.Delete history 
when there are inputs that have to do with the shape.We don't want the construction history to 
show and be evaluated every time,not to mention sometimes those connections can have a 
negative effect on something you are trying to do.It's good practice to have the control as 
clean as possible.

An example of a clean control before and after translation:
Before



After

Try to use the CV curve tool more since it doesn't have texture on faces and doesn't  
need to render the control.

What varies is the different configurations we can do on them.For example we can 
make  a  control  for  the  ikHandle  of  the  leg  which  moves  it  around,does  not  rotate  but 
scales,pretty standard.We can also make a control for the clavicle ikHandle that instead of the 
usual  transformations  only  has  one  attribute  that  controls  the  twist  attribute  of  the 
ikHandle.We can always  add more attributes  in  the  controls  and our  limit  is  mostly our 
creativity.

The controls for the rig we used on Ryan consist of the Reverse Foot Lock System we 
talked about it in the Skeleton section (because it is joint based afterall) and a set of controls 
for feet, knees, hips, abs, chest, back, neck, shoulders, elbows, wrists and facial controls as in  
controls for the lips, eyebrows, nose, jaw, eyes and one for the head as a second layer of 
rotation apart from the neck control.Lastly we have a global control that controls all others,an 
easy way to move the whole rigged character arround.

Here is how Ryan looks after all controls are in place:
Body



Face

See Appendix section D for a step by step guide to creating them.



2.5-Group Structure and Parenting
As in anything people do, a certain degree of organisation is needed.If you take a look 

in the Outliner you'll notice that things are chaotic and crowded.Already there are so many 
items in there that force you to scroll  down and search for nodes by looking at  most of  
them.What if there was a well defined structure?That would certainly help things.It would cut 
down on the time needed to find the node we are looking for and it would also make it easier 
for us to remember what kinds of nodes there are in our project.

But organisation simply for the benefit of tidyness is not the only reason for using 
groups and creating a hierarchy.Groups are often used to achieve certain behaviours when 
constraining(see 2.7).Sometimes we want some control to be influenced by another but still 
be able to move independently at all times.For example the elbow lock,we want the elbow 
control to follow the wrist control but still be able to move on it's own whenever the wrist  
control is set on some position.

Let's explain the structure for a bit,we have one main group that holds everything 
about  Ryan.That  is  the  Ryan_Anatomy  group.Under  that  we  have  three  groups: 
JointsGRP,ControlsGRP and GeometryGRP.From the names it's  pretty easy to understand 
what nodes they contain.Under the JointsGRP we have the skeleton and some nodes that 
absolutely have to be parented under the HumanoidRoot.All controls and ikHandles will go 
under ControlsGRP and all meshes(11 in this case) will go under GeometryGRP.

We will proceed to create all groups we will need and leave the explanation for why 
some of  them are  needed to  the  Constraints  sub-chapter(see  2.7),not  all  groups  need an 
explanation, those omitted are just organisational groups.We will also parent the objects on 
the scene to other objects  or to the newly created groups.The easiest way to parenting is 
through the Outliner.Whenever we say "parent something under something else" it means to 
drag the selected objects using the middle mouse button pressed on top of the object we want 
to  parent  them  under.A  convention  we  use  is  that  all  groups'  names(apart  from  the 
Ryan_Anatomy node) will end with "GRP".See Appendix section E for a step by step guide 
on Ryan's structure.

Ryan's Structure:



2.6-Locators
Generally locators are not necessary but in this case they proved otherwise.As it turns 

out sometimes constraints even without offsets cannot preserve zero rotations on joints.One 
way to prevent non zero rotations in the joints is to create locators and have them act as 
middle  men  whose  only  job  is  to  decode  the  transformations  proposed  by a  Control  to 
transformations for a joint.We will make use of a mel script to match the transformations of  
the locator to those of the joint to avoid the tedious manual way.The reason is that we don't  
care if we parent or parent constraint (with offsets) the locator  to a Control thus leaving non 
zero rotations on the locator but we do care that the joint influenced by that locator won't 
have non zero rotations in the base pose(the initial pose,in this case the T-pose).

Using locators I managed to keep zero rotations on most joints(there are some cases 
that cannot be fixed,mainly on the spinal cord).The methodology is:
i)Create a locator(and rename)
ii)Select the locator and then the joint it will influence
iii)use the matchTransformsTool(see Additional Instructions I for the script and for how to 
use scripts)
iv)parent the locator under the control object that is supposed to control the joint in question
v)constraint the locator(Driver) to the joint(Driven) without offsets.
Using the control afterwards,we can see the joint gets influenced.

An example of a locator and control system:

As you can see we have the wrist control rotated which has rotated the locator(white 
cross).The locator,in turn,rotates the wrist joint all the while keeping zero rotation values in 
the original pose.

There's also a naming convention to be mentioned.The locators are named as follows:
locXXX_(joint name),loc for locator,XXX is the three first letters of the type of constraint 
that it will impose on the joint and the joint's name after the underscore.There are only three 
types of constraints that we'll use with the locators and they are:Par for Parent Constraint,Poi 
for Point Constraint and Ori for Orient Constraint.So if a locator is called "locOri_l_wrist" it 
means we will use the locator to impose an Orient Constraint on the l_wrist joint.

For now do not concern yourselves with the Constraints,they will  be explained in 
depth in the next section and you will get an insight as to why we used each of them and 
when to use them in general.



Check Appendix section F for the step by step guide of Ryan's locators.

2.7-Constraints
Everything that came after the Skeleton creation has been for the sole  purpose of 

making the model easier to animate.We added ikHandles to connect the joints  from joint 
subchains as logical parts(arms,legs,torso etc).We added Controls that will be used to control 
those  logical  parts  without  the  animator  being  bothered  by  things  that  work  on  the 
background, keeping offsets where needed.Constraints exist to reinforce the notion of making 
things easier for the animator.We may have constructed logic parts but there are a lot of extra 
rules we can impose to induce a natural feel to it.

We can't always use parenting because it doesn't make sense.Why parent the skullbase 
joint under the neckControl or the headRotationControl(disregarding that the name suggests 
only rotation for the sake of the argument)when everyone knows we can't move (caution: 
move as in translate only) that part of the head when the neck is perfectly still?We can only 
rotate.Therefore  it  makes  sense  to  just  constraint  the  orientation(meaning rotation  at  this 
point) of the skullbase joint to the headRotationControl and leave the translation of the head 
to the neck and neckControl which is the natural way a human neck and head work.

We have talked about the purpose of this feature,but haven't really explained what it 
does and how it works.To quote Maya Help Files,"Constraints enable you to constrain the 
position, orientation, or scale of an object to other objects. Further, with constraints you can 
impose  specific  limits  on  objects  and  automate  animation  processes".[8] Basically,the 
constrained object has values for position,orientation and scale imposed on it,overriding it's 
independent  transforms(meaning if  we move the  constrained Object  A,the  transformation 
values won't be changed since it is constrained to another Object B).We call the constraining 
object the driver and the constrained object the driven.
To make things clearer,let's talk about the types of Constraints and what they do.

Constraint Types:
*Point  Constraint:constraints  the position(translation channels  or attributes if  you 

like)  of  Object  A(Driven)  to  Object  B(Driver),or  to  the  average  position  of  several 
Objects(Drivers).

*Orient  Constraint:constraints  the  orientation(rotation  channels)  of  Object 
A(Driven) to Object B(Driver).

*Scale Constraint:constraints the scale of Object A(Driven) to Object B(Driver).
*Parent Constraint:constraints the position and orientation(translation and rotation 

channels) of Object A(Driven) to Object B(Driver).One might wonder why parent constraint 
instead of point and orient constraint at  the same time.The answer lies on the fact that a  
parent constraint,like the parent function,treats the constrained objects like parts of a bigger 
object containing the constraining and the constrained objects ,whereas a point constraint and 
an orient constraint are applied to the individual constrained objects.For example if we have 
an Object A parent constrained on Object B,rotating Object B will treat both objects as one 
object rotating and it's pivot is the pivot of Object B,therefore Object A will move on a course 
around Object B.On the other hand if  we have Object A point and orient constrained on 
Object B,rotating Object B we'll see both objects stay in place and rotate around their own 
pivots.

*Aim Constraint:constraints the orientation(rotation) of an Object A(Driven) in order 
for it to aim or point at ,if you will, an Object B(Driver).

*Pole Vector Constraint:"A pole vector constraint causes the end of a pole vector to 
move to and follow the position of an object, or the average position of several objects. " is  



what  Maya  Help  Files  defines  it,but  I  find  it  a  bit  inadequate.[8]We  use  pole  vector 
constraints in the knees,elbows and clavicle/shoulderblades.It's puprose is to constraint the 
rotate plane ikHandle there to the position of an object.The effect we get out of it is,the pole 
vector(the  handle  vector  connecting  the  rotate  plane  disc  with  the  end  effector)  rotates 
itself.This way we can simulate the rotation our elbows can do with the hand and shoulder in 
a locked position(their rotation not included).In this  case the Driver is the object and the 
Driven is the ikHandle.

In the image example of the previous section,the wrist locator is the driver on a point 
constraint with the wrist joint as the driven.

For more information please check the Maya Help Files.[8]

There are,of course,other types of constraints but these six types are the most basic 
types and the only ones needed in this project.See Appendix section G for a step by step 
guide with detailed explanations in the uses of constraints for Ryan.

2.8-Custom Attributes,Connections and Set Driven Keys(Animation 
Curves)

As it is ,the rig is enough to perform basic actions.This is the point where a rigger can 
show how good he is.A rigger has done a perfect job when he makes things so easy for the 
animator to do a very fast and solid job.He has to take into account what the animator is  
comfortable working with but it is also the rigger's duty to be creative and come up with 
things that will make the model feel more natural.

We will make use of features,in Maya,like the ability to create custom attributes for 
anything and either connect them with another attribute or rely on set driven keys to create an 
animation of sorts.

In Maya,we have the ability to add custom attributes to an object.Every object has it's  
own  attributes  and  all  objects  have  the  basic  translation,rotation,scale  and  visibility 
attributes.Sometimes  we might  encounter  an object  that  might  not  have all  of  the above 
shown  in  the  channel  box.In  reality  all  of  the  above  attributes  exist,in  fact  a  lot  more 
attributes are present in every object ,but attributes are classified as keyable and non-keyable.
Keyable attributes are the attributes whose values we can set at will and key in an animation.
Non-keyable are the attributes that cannot be keyed in an animation.There is also the Non-
keyable Displayed,the attributes whose values we can change by cannot key in an animation.
Usually if there is a basic attribute missing from the channel box ,it's probably classified as 
Non-keyable.More information on Cleaning up the Rig see Additional Instructions.

Like we said,apart from the presets of attributes Maya has for it's objects,we can add 
our own. If you go to Edit->Add Attribute on the channel box,a popup wizard will show up,a 
wizard  that  will  help  you  create  the  new  attribute.you  can  give  it  a  name(Long  name 
box),classify it  as  Keyable,Displayable(Non-keyable)  and  Hidden(Non-keyable),define  it's 
data type(we will be using floats and booleans mostly),set a default,minimum and maximum
value(if it makes sense,ie maximum doesn't apply in boolean attributes) and lastly define the 
Enumeration field names if it is an Enum type attribute.To give you an example of what we 
can do with custom attributes,the hand can form a fist when rotating the fingers towards the 
inside of the palm.We could create a float attribute in the wrist control,by the name Fist,and  
connect the rotating of the fingers towards the inside of the palm with the float attribute in a 
way that increasing the value of the attribute rotates the the fingers a little bit more,maybe 
even have a maximum value of 10.00 where the hand has formed the fist.Or we could make 



the Fist attribute a boolean type where the hand forms a fist when the Fist attribute is on and  
an open palm when it's off.

However,creating  custom  attributes  cannot  make  those  connections  between  the 
values and the channels we want to manipulate(in this case the Fist attribute and the finger ,or 
better yet finger joints' rotation attributes).For that we have to create a connection.There are 
two  kinds  of  connections  we  can  make,Connections  and  Set  Driven  Keys(or  Animation 
Curves).The difference can be summarized in the parenthesis.Set Driven Keys are a way to 
create animation curves,as the name suggest they are keys from an animation that can be 
driven.For example,one can set a lock system on Object A in relation to Object B,Object A 
will follow the movement of Object B as long as the lock attribute is on.When that attribute is 
off ,Object A no longer follows the movement of Object B.To explain a bit further,there is a 
point  or  parent  constraint  with  Object  B  as  the  driver  and  Object  A as  the  driven  and 
constraints have on and off states,in their channel box you can see the driver as an attribute.If  
the driver attribute of the constraint is set to 1 then the constraint is applied,if it is set to 0 
then it does nothing.When the lock is on you set that driver attribute to be 1 and 0 when the 
lock is  off.On the other hand,Connections are totally different.They feed whatever values 
from the driver attribute back to the driven attribute(by using the words driver and driven,it 
might sound like a constraint,remember constraints are only for object to object relationships 
and connections/set  driven keys  for  attribute  to  attribute  relationships  ).If  you  go to  the 
channel box of Object A and open Edit->Connection Editor you can see the attributes of 
Object A on the left side.If you select that constraint node and reload on the right of the  
connection editor you will see the constraint attributes on the right side.There you can select 
attributes from each side and connect them.For example the lock attribute from the left to the 
driver attribute on the right.It will work because there is some semblance in their intended 
codomain or set of valid values.On is 1 and 0 is off and the other way round.If the attributes' 
codomains do not match at all then a connection cannot be made.After selecting the lock 
attribute you will see that a lot of the right side attributes have been greyed out,that's because 
they cannot form a connection with the select attribute.

Both methods though have their merits.When you have to connect two booleans or a 
boolean with a float that you only want to have 0 and 1 as values or when you want to  
connect two floats,the easiest is to use the Connection Editor.When you have elaborate states 
it's best to use the Set Driven Keys and some times inevitable.

Some examples of things you can do:
i)Foot Roll:a float attribute where certain values mean different poses for the Reverse Foot 
Lock joint controls(ie when the Foot Roll has a value of 6,the heel of the foot is raised and 
the toes and metatarsal are firmly on the ground,when the Foot Roll has a value of 10,the heel 
is raised and the rest of the foot is in a straight line with the heel,basically the foot touches the 
ground only at the toes)
ii)Knee and Elbow Locks:Sometimes we want the knee and elbow controls to move along 
with the arm instead of remaining at the same position,others we want them to remain at the 
same position.We can connect  a  boolean  lock attribute  to  a  point  or  parent  constraint  to 
enable or disable it depending on the lock attribute's value.When on,the knee or elbow control 
follows the leg or arm respectively and when off,they remain at their previous position.
iii)Blink:we can create a boolean blink attribute for the eyes where on means the eyelids meet 
and a blink is formed and off means the eyelids are wide open.

For information about the extra features I implemented on Ryan see Appendix Section H.

An example of the Fist feature we implemented on Ryan:



3. Skinning & Animation

Skinning in general is the process of making the skin(geometry) move in relation to 
the skeleton(joints).There are two stages in this process,Binding and Skinning.Binding refers 
to the connection of skin parts or the whole skin to the skeleton hierarchy or a subchain.You 
can bind the whole geometry to all joints  or you can bind the face geometry to the face 
joints,the left arm geometry to the joint subchain representing the left arm and so on.Skinning 
is the part where we try to perfect the deformations that happen when transforming parts of 
the body.If we move the arm downwards to rest it to the side of the torso we don't want the 
rib area to go inwards,we don't want it to deform so much in general.Maya tries to create 
some deformations when binding but  they fall  short  nearly all  the time.Deformations  are 
represented as float values or weights,in the range of 0-1,in a combination of vertex and joint.
A weight is basically a measure of how much a specific joint can influence that vertex.

Officially there are three binding methods,Smooth Bind,Interactive Bind and Rigid 
Bind ,but Interactive Bind is just a Smooth Bind that incorporates a new way of distributing 
the weights for the deformations.

According  to  Maya  Help  Files,"The  main  difference  between  rigid  skinning  and 
smooth skinning is that in rigid skinning only one joint can influence a particular skin point 
(CV, vertex, or lattice point), but in smooth skinning, many joints can influence the same skin 
point. Because smooth skinning allows many joints to influence the same skin point, you can 
immediately  get  smoother  deformation  effects  right  after  binding  skin."[8].Influence  is 
distributed by the use of the Paint Weights Tool(Skin->Edit  Smooth Skin->Paint Weights 
Tool[]).You can see the list of joints on the left and configure the brush you will be using.By 



selecting a joint,setting the Value to 0.2 and painting over a part of the geometry,you are 
setting the influence the selected joint has over the vertices of that part of the geometry to 0.2.

An example of painting weights in Maya:

Interactive  Binding  on  the  other  hand  is  smooth  skinning,but  the  distribution  of 
weights and influence is done by the use of capsules.It's exactly what it sounds,after binding 
you will  see a capsule like object on top of the geometry with it's  own manipulators for  
scaling everywhich way and fitting it over an area of vertices in order to place influence upon 
them,influence by a specific joint every time.You can see the distribution of influence on top 
of the geometry and decide if  you need to cover more vertices and use the manipulators 
accordingly.

For Ryan I used Smooth Binding,binding every geometry part  to a specific set  of 
selected joints.It is another good reason for having the geometry in parts.When there is a need 
to fix the weights of the left arm for example,we don't need to mess with the other parts.Even 
if we have to detach,or unbind if you will,a geometry part from the joints to perform the fix  
we have to do,we don't have to mess with the other parts.For the skinning method,there are 
three choices."Traditional smooth skinning in Maya uses linear skinning to make a mesh 
follow a character’s joints. In areas such as the wrist or elbow, this method can result in a  
'bow tie' or 'candy wrapper' effect where the mesh loses volume as a bone twists on its axis. 
The  dual  quaternion  smooth  skinning  method  is  designed  to  eliminate  these  undesirable 
deformation effects. While linear smooth skinning allows a mesh to collapse or shrink when a 
bone twists, dual quaternion skinning helps to preserve volume in the mesh, creating more 
realistic deformation in those problem areas" is what is written on the Maya Help Files.[8]As 
you can see their difference lies on how they deal with volume loss.Dual Quaternion deals 
with volume loss but it is not perfect,and Classic Linear does not deal with volume loss.My 
pick was on the third skinning method,Weight Blended.It is a blend between the two previous 
methods.It  deals  with  volume loss  just  like  Dual  Quaternion but  is  highly editable.Then 
there's the normalization of the weight values,the influence you paint must be between 0 and 
1.Between the three choices,I chose Interactive because I wanted to see the result as soon as I  
painted the influence instead of Post where you have to rely on the weights to be updated 



every time you deform the mesh from the normalization.I  also don't  allow multiple  bind 
poses because that is generally not accepted,by other people or other software.The setting for 
Max Influences I chose was 4,meaning that a vertex can have a maximum of four joints 
influencing it.But I also chose not to Maintain max influences which means that the setting 
for Max Influences is just  a default value and that in the case where we need a vertex to be  
influenced by more joints,it will be doable while the rest of the vertices remain at 4(max).The 
rest of the settings can be left at their default values.Hit Bind Skin and it's done.Now there is 
a connection between the skin mesh and the joint subchain in the form of a new node,a 
skinCluster  node.You can  view it  by selecting  a  skin  mesh and checking it's  inputs.The 
skinCluster node,apart from connecting the skin mesh to the selected joints,also contains the 
skinning information,weights,influence or whatever other name can describe it.After binding 
all geometry parts,you can begin to paint the weights.

Unfortunately,painting weights is not a task that can be instructed step by step,moreso 
it requires experience and knowledge of the human body.Not a task a beginner can do from 
the  get-go.For  the  beginner,this  task means a  lot  of  trial  and error  and besides  giving  a 
workflow to work with ,I cannot do much else.When I started painting weights it took me a 
lot of time to grasp at the logic.Furthermore I had made the mistake of trying to bind the 
original geometry with over 11 geometry parts.Skinning so many parts is very difficult.A 
master skinner might have done it but for a mere beginner it was impossible.After that I tried 
binding and skinning with the geometry as one whole part.Again I failed.To make matters 
worse when the  geometry is  one whole  part,binding gives  all  joints  access  to  the  whole 
skin(all  geometry vertices).That  means,joints  totally unrelated to certain body parts  could 
influence their vertices.In Interactive normalization,the weights are normalized as they are 
painted,if  we try to remove influence from a joint because it  might not be desirable that 
influence has to go somewhere else,meaning another joint,to make sure the sum of influences 
on the vertex is 1 at  all  times.However,Maya doesn't  do a good job placing the removed 
influence on appropriate  joints  and you might  end up having,say,a  foot  joint  influence a 
vertex on the nose geometry.

All of the above problems lead to using the geometry partitioning I talked about at the 
beginning.Having  parts  but  in  moderation  helps  considerably,only  selected  joints  can  be 
bound to a geometry part,eliminating unrelated joints' influence on that geometry part,and 
when the skinning for that part reaches a point where it's satisfying it can be left alone and 
won't be hindered unless we do something directly on it.The only difficulty in this approach 
lies on the seams.The seams are the vertices around the place where two geometry parts  
meet.For example the seam for the torso and left arm lies around the end of the shoulder,in 
Ryan's case.But a little hard work there is justified when considering all the advantages of 
this approach.

The workflow I suggest you work with is an iterative one.But first there is a part that 
needs attention if you are to use this workflow.This workflow relies on the use of weight 
maps.Weight maps are exactly what the name suggests.Specific files that store information 
about the weights you've painted on a single geometry/mesh.

At runtime,they are like two-dimensional arrays,joints on one dimension(ie columns) 
and skin vertices(ie rows) on the other,and the cells store the weight value the joint on that 
column has over the skin vertex on that row.To get a feel for it you can see the Component  
Editor,a very important tool in skinning.Many don't even know of the Component Editor's 
existence but it is imperative that you use it because there are things the eye can't see when 
using the Paint Weights Tool.When using the Paint Weights Tool,there are two ways of seeing 
influence on skin,the values from 0 to 1 are represented either in the greyscale(meaning the 
colors  between white  and black,white  being an influence of  1  and black an influence of 
0).The problem though is that sometimes we might confuse a very dark grey with black.Even 
blindly  painting  with  zero  influence  is  not  effective.It  seems  Maya  hasn't  perfected  this 



system.But,defending  Maya,they  did  include  the  Component  Editor(Window->General 
Editors->Component Editor).As the name suggests it's  used only in component mode.You 
first  have  to  go  into  the  component  mode,select  some  vertices  and  then  open  up  the 
Component Editor to see what weights they have upon them and by which joints.It can be a  
tedious job trying to find unrelated influences and zero them out but ,trust me,it's one of the 
things that will save you time and effort.Especially when weights have been misplaced on 
vertices,it is the only tool that can guarantee you will find and fix the problem quickly and 
safely.

Back  on  weight  maps,there  is  a  prerequisite  to  be  able  to  use  this  feature.A 
prerequisite that requires I explain some things about texturing and UV maps.Maya Help 
Files define textures as "any kind of surface detail,  both visual and tactile. In Maya, you 
create  surface  detail  with  textures  connected  to  the  material  of  objects  as  texture  maps. 
(Materials define a the basic substance of an object; see Surface shading for more details.) ".
[8]For  example  in  a  humanoid  like  Ryan,textures  are  the  image  files  that  have  his  skin 
color,hair color,wrinkle detail,makeup or any kind of detail for how he looks.We apply those 
textures over the model to make the model look real.Before textures the geometry is at best a 
colorless surface.What makes it real is the textures and shading(which we don't need to talk 
about yet).But even so,how do we apply those textures which are 2D on a 3D model?This is 
where UV maps enter the picture.UV maps are 2D texture coordinates.Shapes that define 
where  each  part  of  the  texture  rests  on  the  3D  model.UV  maps  are  created  before 
textures.After modelling the character,we unfold the geometry into a 2D shape.Imagine those 
animal skin rags,they are exactly what you want to do to the geometry.You define seams and 
cut the geometry across them until the geometry is unfolded.The resulting shapes are layed 
out on the UV space and we get snapshots of them in order to create the texture with those 
shapes as references.

An example of UV mapping over textures for the Face mesh:



Weight maps are basically images per joint that contain the same shapes as the UV set 
but  instead  of  the  colors  the  texture  has,it  stores  the  greyscale  values  of  weights.When 
imported back to Maya,the image gets decoded into influence values from 0-1 depending on 
the  shade  of  grey,white  or  black  in  the  weight  map  image.That  image  contains  all  the 
influence the joint ,it was named after, has over the skin part.For example, if we exported the 
weight map of the left arm mesh,there would be an image called l_wrist(not quite,as there is a 
naming pattern but this is an example) with the whole left arm unfolded and containing some 
greyscale values on top of the wrist part of the arm.

An example of a weight map,from the lower Jaw Pivot joint on the Face mesh:

Weight maps only work when the UVs are set in a way that no two UV parts/shapes  
overlap.If they do, the information that is exported is messed up.This was an early problem in 
Ryan's case.His UVs where overlapping and texturing and UVs are not a subject a rigger/ 
animator has to concern himself with.Nonetheless,it is worth dealing with.As long as there 
are UVs and textures available,even someone with no knowledge can correct them.It requires 



extra work and some roundabout ways of fixing but weight maps are convenient enough to 
justify the extra work.For more information about how to fix the UV maps and textures for a 
3D model see Additional Instructions.

An example of overlapping Uvs that we have to avoid:

Both images are taken from the same UV set,yet there are two textures.The reason is 
that different textures are assigned to the face and the neck,both of which share the same UV 
set.On the left image we have selected a UV from the face and we get the face texture and on  
the right image we have selected part of the neck UVs and have gotten the body texture.You 
can see that the overlapping happens on the upper right part where the neck UVs overlap with 
the face UVs.If we try to export the weight map from this version of UV set, the result will be 
something messy.You have probably noticed by now that weight maps are a snapshot of the 
weights according to the UVs.If you check the example of the correct UVs and the example 
of  the  weight  map  given  earlier,you  will  see  that  they  have  the  same  shapes  and 
positions.Imagine now what would happen if we had overlapping.When Maya tried to take a 
snapshot of the weights ,it would confuse the upper part of the head with parts of the neck so 
we would get wrong weights in the end.

Last but not least we have to talk about Animation.We all know what Animation is,but 
what does it mean for Maya?Animation in Maya is basically taking "snapshots",keyframes is 
the official term, of the attribute values in certain points of time.You can see the time slider 
on the bottom part  of Maya.It  is  a  linear  depiction of  time measured in  frames.To set a 
keyframe or key in short,we select a frame in time,either on the slider or manually setting the 
value on the box right of the slider,then right click on the attribute we want to key and select 
Key Selected.There are other ways but let's focus on one.We want to create an extensive 
animation for the controls so that we can test every change in skin weights immediately. 
Whenever we paint some influence we play parts or the whole animation to see if the result is 
solid.One way to be quick about it is to use Character Sets.Character Sets are nodes that hold 
attributes from several member nodes that you define and whenever you press the S from the 
keyboard,which  is  the  shortcut  to  set  a  keyframe,every  attribute  in  the  Character  Set  is 
keyed.Basically it's a way to take a snapshot of all nodes instead of keying one attribute of 
one object at a time which is the regular way.

The workflow I suggest is the following.First off,save the file you're working on in a 
new one and have the old one as a backup for good measure.Create an extensive animation 
(keyframes for lots of positions for every control).Start painting weights for a geometry part  
and play the animation as often as you can to test if what you paint is good and natural.Do 



that as many times needed until you feel satisfied from your work.Exporting weight maps 
during this process might be good but only as long as the number of the exported weight 
maps is low,it gets confusing after some point to remember what kind of information each of
those maps have.For now do not concern yourselves with the seams between the geometry 
partsDo the same repetitive work for every other geometry part and make sure to export their 
maps at the end.Now the only thing remaing is to work at the seams.Again,test the weights 
out by playing the animation or parts of it.In the end export the final weight maps and keep 
them in a safe place.Painting weights can be a painful ordeal for a beginner and there are 
many dangers to risk having just the one file you've been working on.Now even if you need 
to change something,say,the position of a joint for which you have to detach the skin first,all 
you need to do is import those maps or the maps you need back after the change is finished.

If by any chance you can't export weight maps because of the UVs overlapping and 
choose  not  to  fix  them,there  are  ways  which  you  can  work  with  but  they  are  very 
cumbersome.For the sake of being complete,in case there is a change needed,you have to 
create a new scene,import rig(skeleton with constraints,controls,ikHandles etc) and geometry, 
fix it,bind the skin to the rig,import the file you were working on previously and copy the 
weights from one skin to the other.One disadvantage is that you have to do import whole files 
over and over which by itself takes a lot of time and another is that almost every time you 
import a whole file there are nodes that you don't know about that get left behind and crowd 
the file you are working on making it slower to load your files every time.There are two ways 
to fix this.Either by selecting all nodes from the Outliner you want to keep and Export the 
selection(File->Export Selection[]) to a new clean file,or in the Outliner go to Display and 
uncheck DAG Objects Only,that will show every node there is in the file and you can see a  
lot  of  nodes  with  namespace  in  front,a  namespace  matching  the  name  of  the  file  you 
imported.You can just delete those nodes and it will be ok but i don't recommend this solution 
unless you've gained some experience in the use of Maya and knowledge about it's inner 
workings.

4. Blendshapes

The result from the previous section is a rigged and skinned version of your model, 
and in my case Ryan, with a joint based facial animation.But that is not the only way we can 
perform a  facial  animation.Blendshapes  are  based on the  principle  of  morphing between 
copies of the target mesh that have been altered.It's disadvantage is that you have to prepare 
as many of those copies as possible to be able to get a wide variety of results.

It  sounds  a  bit  difficult  to  grasp  but  the  following example  will  clear  everything 
up.Since we talk about facial animation,imagine the target mesh being the Face.Also imagine 
the altered copies to be literal copies of the mesh where we've altered the vertex positions in  
order to create expressions like sad or happy or frown and so on.A blendshape node is created 
out  of all  those copies and the target mesh which is  the Face of the model.If  you go to 
Window->Animation Editors->Blend Shape,you will see the newly created blendshape node 
and a lot of sliders.Those sliders are like weights and imply the percentage of each copy that 
will be used to blend with the others and create the result.For example if you slide the sad and 
frown sliders you will see that the model's face has a sad face with a frown.

The level of the facial  animation we can achieve by using blendshapes is  entirely 
dependent on the creativity of the rigger and the variety of different faces he can produce in  
order to have a bigger variety of end results.



An example of the expressions we used with Ryan:

At this point we need to prepare our model for the use of blendshapes.Firstly,save the 
fully rigged version of the model in a new file which will be the blendshape version of the  
model.There is no reason to start anew when the only thing we need to change is the facial 
animation style.Also having the skin in parts  has already paid off  since we only need to 
meddle with the Face mesh and all else remains as they were.Before deleting anything we 
have to detach the face skin.Now that the skin is not bound any more we can go and delete 
the facial controls group and then all joints from the skullbase up.Now we have to rebind the 
face mesh to all those joints remaining of those we used for the fully rigged version.Next we 
have to reskin the face.We could avoid this by importing the fully rigged version of Ryan just 
this once and copy the skin weights with the settings looking for the closest joint to attribute 
the influence when joints are missing from the target subchain.The goal is to have the exact 
same weights up to the last joint of the neck(which in our case is vc1) and have that last joint 
take all the rest of the weights from all the missing joints in order to pull the mesh whenever 
the head moves.Then we just need to create the blendshape node and control the morphing 
from  the  Blend  Shape  Animation  Editor.For  more  information  about  how  to  create  the 
blendshape node and make it work see Appendix section I.

5. Feature Points

Even though this is a part that goes in both versions of the model I thought it best to 
write after blendshapes since the feature points system I used is based on them.Feature Points 
are features on the body that influence the skin without actually being part of the skeleton. 
There is  a variety of  uses for Feature Points.One of  them is  to  manipulate  geometry.For 
example, make the model fat or muscled etc.This is but one of those uses.Another possible 
use would be to have the feature poins in the face act as reference points for motion capture 
and better facial animation.There is a list of Feature Points in the H-anim Standard[6]. 

Normally we should have included them as influence objects in the geometry parts' 
skinning. Influence objects are just like the joints,objects that are considered able to influence 
skin vertices.But I found this approach not as convenient as I'd like.As influence objects ,they 
had to have some influence over the skin,but that meant taking portion of the influence from 
the other joints,skeleton joints  mainly,and giving it  to the feature points,spoiling the hard 
earned result.There was a need for an extra layer of weights which would influence  the 



already influenced,by the skeleton,skin without mixing the influences  up,and blendshapes 
where  exactly  that.More  specifically,the  second  layer  I  wanted  was  to  be  found  on  the 
skinClusters of the copies of the geometry,imported in order to be simple blendshapes to the 
original model.In short,we bind the blendshape-intended geometry to the feature points plus 
one  joint  to  act  as  a  root,paint  their  weights  to  our  satisfaction  and  in  the  end  create 
blendshapes for every geometry part(Only the main parts.Eyes,tongue and teeth were not 
needed).The blendshape-intended geometry parts had their own weights and by the use of 
blendshape mechanics influenced the fully skinned original model.For more information on 
how to create Feature Points and connect them to the original body through blendshapes see 
Appendix section J.

An example of Ryan's Feature Points:

On the left Ryan we have the feature point joints and on the right Ryan we have the 
feature point controls.

6. The Convenient Alternative of Scripting

During the process of this thesis,a fair bit of MEL scripting was used.At first mostly in 
the  form  of  small  scripts  for  the  odd  job  here  and  there,selecting  all  joints,matching 
transformations or positioninig an object to another,the creation of a box curve or a joint 
shaped  curve.They  were  helpful,but  I  still  had  to  go  back   in  versions  in  order  to  fix  
something.That took time,and moreso when in the better part of the time used for this thesis I 
hadn't tried to fix the UV maps,leading to increased workload and time needed for the fixes 
each time.Any beginner to the field wouldn't meddle with UVs that easily and even with 
some knowledge for rigging they're bound to make mistakes.Another thing I hadn't tried my 
hand at first was MEL scripting.MEL is the Maya Embedded Language,in other words the 
scripting language that runs beneath all functionality in Maya.Everything you do is a MEL 
command in one way or another,something you can see for yourselves by opening up the 
Script  Editor  after  doing  something  like  creating  a  joint  or  a  locator  and  moving  it 
around.MEL can be scary for the beginner but I realised after having used the scripts many 
times and seeing MEL solutions all the time,that it wasn't that hard afterall.Moreover,there 
are  a  lot  of  riggers  that  scarcely  do  any work  with  Maya's  GUI  but  work  mostly  with 
scripting.MEL scripting can be very convenient,especially to a beginner who tends to make 
mistakes that cost him/her time.



The truth is,one can script the entire process,save some parts which are not realistic to 
script because of the sheer number of commands involved and the possibility of bringing 
even a machine with a good deal of processing power to it's knees.Apart from skinning where 
we can just import the weight maps we've created,all else can be scripted.With just the entry 
of one command,Maya can read a network of scripts,each one reponsible for the creation or 
manipulation of some component,and do everything automatically.In fact,this whole thesis 
has been scripted.

The easiest way to learn MEL is to see what commands are executed when you do 
something in Maya.Also Autodesk's MEL commands index is very helpful and there is a fair 
number of sites containing custom scripts ,from simple to elaborate.

When scripting parts of the process it is that faster to fix something.You don't need to 
import rig and geometry and bind anew only to import the whole previous and faulty version 
to copy weights from, to the newly bound skin,if all that needed fixing was the position of a 
joint.You just need to change the position in the specific joint's creation command,run the 
script from scratch and then correct the weights,something you would have to do anyway.

7. Exporting to COLLADA

We've successfully rigged a model,skinned it,animated it,created two forms of facial 
animation  and  now  it's  time  we  exported  it  to  COLLADA.Maya  does  not  come  with 
COLLADA import/export plugins installed so we needed to find one.The plugin used was 
openCOLLADA(details about how to install and enable it in Additional Instructions).

First off,COLLADA does not support blendshapes so we know that only the version 
with the joint based facial animation makes sense to export.Also COLLADA does not support 
constraints,splines(as they call every object with a shape node,which means all controls we've 
used apart from the RL joints won't get exported).Moreover,to exporting animation is not as 
flexible as one would like.The exporter itself is in a rather early stage.

For now,we want to ,at least, export  just the basics:skeleton,geometry along with the 
skinClusters,  the  skinning  information  and  textures  and  finally  animation.Exporting  the 
skeleton is easy enough.Some problems might arise when exporting geometry in terms of 
shaders and textures but they can be solved by the same method we fix UV maps(more about 
this  at  Additional  Instructions).Animation  ,though,  is  the  biggest  obstacle.Since  we  can't 
export  any  controls  ,we  can't  export  their  animation.But  why  should  we  care?Joints' 
animation is what we need exported.Indeed we create a character set for the joints only.Then 
animate the model and the character set,containing only joints ,will be responsible for storing 
the joints animation.But it seems that constraints,controls and animation curves apart from 
the ones created in last animation we made,do not agree with the openCOLLADA exporter 
plugin.The fact is that to be able to export the animation along with the rest of the basics we 
have to delete and invalidate things.Hence the earlier remark about the exporter being in an 
early stage.If one tries to export this to COLLADA,either the animation won't be exported,or 
animation curves(from extra features or driven keys) that shouldn't be there will be exported 
instead of the intended one,or maybe the animation will get exported but the skinClusters 
involved will be somehow detached.

Since the exporter is capricious we have to act.We have to get rid of all nodes that will 
stand in the way which are quite a few.In fact some of these nodes have to be deleted even 



before  the  joints  character  set  is  created.The  reason  is  that  we  want  the  joints  as 
connectionless as possible in order to create the character set without skipping joints.Apart 
from  the  constraints  and  connections  we  don't  want  any  animation  curves  from  driven 
keys,meaning we have to invalidate the work we did on several parts of the project.After 
deleting  the  animation  curves,we create  the  character  set  for  the  joints  and if  there's  no 
warning we proceed.We animate the model using the controls,but having the joints character 
set enabled ,only joints will get keyframed,which means the new animation curves will be the 
correct  ones.Afterwards  we have to  delete  the character  set  so that  the animation curves 
created will be seen by the exporter.Then it's the whole control system we have to delete, 
meaning ControlsGRP,and let's throw the FeaturePoints GRP in the mix if there is one since it 
was created with blendshapes and is useless when exporting to COLLADA.We don't want the 
exporter to try to export constraints,ikHandles and other troublesome nodes that might mess 
with  the  animation  curves.We  also  have  to  delete  the  visibility  layers  and  make  sure 
everything in the scene is visible before exporting.The clusters and the spine spline curve that 
rest under HumanoidRoot have to be deleted too.If you drag the time slider you will see that  
the animation is there even if you just deleted half of the project.Now it's time to export.The 
export settings are detailed in Appendix section K.

An example of the exportable edition of Ryan:

What you see,skin and joints,are the only things left after cleaning up the file for the 
exporter to do it's job properly.Of course we have the animation curves for the joints and the 
materials' nodes too,but they are are not renderable nodes.



Results

We have learned how to rig a 3D model and how to animate it.All that for the sole  
purpose of exporting the final product in COLLADA to see what gets exported and what 
doesn't.The exporter for COLLADA doesn't support everything the Standard supports yet,but 
both of them need a lot of work before we can include them in a professional production 
pipeline.It is a fact that any kind of spline or NURBS curve(automatically all of our controls) 
cannot be exported.Also constraints and connections in general cannot be exported.Visibility 
Layers  either  have  to  be  all  visible  or  deleted.Clusters  too  are  not  supported 
fully.Kinematics,although  supported  in  COLLADA 1.5,haven't  been  implemented  in  the 
import/export plugin yet.Already,we have 60+% of our work unexportable.To make matters 
worse,exporting animation requires the user to meddle with things.First in order to create the 
animation  one  has  to  use  a  character  set  for  all  joints  in  order  to  store  joint  animation 
somewhere for the exporter to find.Moreover,in order to export the animation,all of the above 
unexportable nodes,including the character set for the joints, must be deleted in order to leave 
just the exportables.That is because the plugin cannot distinguish the animation curves we 
need to export when there are controls and constraints in place.In the end we delete so much 
of our work,work that is essential in production pipelines,and export just the bare minimum.

Here is a gallery of images at every stage of this process:
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Constraints

Skinning
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Blendshapes





Export to COLLADA

Joint Based Version of Ryan



Blendshape Based Version of Ryan



Validation

So far we've described how to rig,skin and animate a character.We've even exported 
the character to a COLLADA file.Now we need to validate the result and prove it works.

There are two ways of validation.The first one is to import the COLLADA file into a  
new scene in Maya through the openCOLLADA importer plugin.However it is not a surefire 
way.The second one is to load the COLLADA file in the OpenSceneGraph animation viewer 
application.OpenSceneGraph requires you compile the whole source from scratch,to create 
the  applications.Among  those  we  can  find  the  osgViewer  and  osgAnimationViewer 
applications.They  can  both  load  a  COLLADA file  but  only  the  second  can  play  the 
animation.If you've followed the instructions at the Exporting to COLLADA section carefully 
,you will have no problem viewing the model and playing it's animation.

A screenshot of osgAnimationViewer running the animation of Ryan:
Simple View

Running Animation



Conclusions

Starting this project,we set out to test how well the COLLADA Standard can stand 
when  used  to  transfer  a  rigged,skinned  and  animated  character  from  Maya  to  another 
software application,in order to see if it is satisfying enough to be used by professionals.We 
later learned that after creating all that functionality ,that the exporter can export only a bare  
minimum out of it.Therefore we can't suggest it for usage in a professional pipeline yet.In 
fact the exporter needs a lot of work to catch up to the Standard,and frankly the Standard 
needs more work too.

However,if we change our objective ,the exporter delivers.If we just want to transfer a 
finished product then the job is done.Through some direct meddling from the rigger/animator 
we  can  export  the  skeleton,geometry,textures,binding  and  animation.While  it  is  the  bare 
minimum,the fact  that  we can transfer  a  fully rigged and skinned character  into  a  game 
engine,  for  example  Unity and Unreal  Engine  support  COLLADA,along with  animation, 
doesn't change.Overall,depending on what type of work we need to do,the exporter delivers 
or not.



Appendix



Appendix A:Adjusting Geometry for Rigging

After confirming the geometry needs modifications,we proceed to make them.As was 
mentioned for this project Ryan was used and in his initial form he consisted of 73 shapes or 
geometry partsToo many for our liking,we had to reduce the number to 6.Assuming that you 
have set visibility layers for those shapes we will need two more for the modifications since 
the merging is done between two shapes.The names of the layers don't matter,they are there 
just for assistance and for our conveniece.Let's name them part1 and part2.We add one of the 
adjoining parts in the part1 layer and the next in part2.We make every other layer apart from 
these two invisible by clicking on the checkbox with a V.When the V symbol does not appear 
then the layer and effectively all of it's members will be invisible.Now that we only see the 
two parts it is easier for us to work.We select both parts in the viewport and go to Display-
>Polygons->Border Edges.This is a preliminary step to assist us in merging them together 
later on which makes the border edges of a shape bold and distinguishable.Then we go into 
Polygons mode to be able to have the Mesh and Edit Mesh menus.We can achieve that by one 
of three ways:a)press F3,b)go to the top left,just under the menus,there is a drop down menu 
and we can select Polygons,c)with SPACE pressed while the cursor is in the viewport we can 
see all  the  menus from all  modes and we can left  click on Mesh or  Edit  Mesh without 
changing modes.Personally i prefer the use of the custom shelf and it can also hold different 
setting instances of the same action.Either way we need to select both parts and go to Mesh-
>Combine.Looking in the Outliner(Window->Outliner) or the attributes area at the right side 
of Maya we can see that a new shape has been created named polySurface1 which is the 
combined geometry of the two parts.But do not be fooled this is not over.Although Maya says 
they are combined in truth they just seem to.The only thing that actually gets combined is that 
both of those two parts are now governed by one node instead of the previous two.If we try to 
skin the character like this there will be crevaces as I like to call them,the places where the 
former edges of the parts get apart forming an opening for example when the arm gets closed 
and we can see an opening around the elbow.That is because they have border vertices which 
are not merged that are basically on top of each other(see Figure 2.2(commonvertex.jpeg)).

So we go into component mode(F8) to be able to work with the vertices,now we can 
see the benefit of showing the border edges from before,and select all the vertices on the 



border edges.Having combined the two parts into one the edges remain bold so it's easy for us 
to distinguish them.After selecting all of them we go to EditMesh->Merge[]  and use a very 
small threshold like 0.001 or 0.0001).What it does is if there are vertices in the selection with  
maximum distance of 0.001 or 0.0001 then replace all of them with one vertex which will 
inherit all edge connections from the replaced vertices.Depending on the model the threshold 
can vary.

Now the vertices are merged and only half of those selected remain.To complete the merging 
of the two parts we return to object mode by hitting F8 again and Delete History.We repeat 
the steps for all adjacent parts slowly reducing the number of shapes/parts until we have the 
parts we want(ie the 6 we mentioned in the modified game artist approach).Caution,there are 
times when the parts are not so clear cut to just combine&merge them in parts and have a  
clear result.For example in Ryan's case,the pelvis shape has part of the blouse.Usually this 
means it just consists of smaller parts and has been combined.To rectify this we select the 
Pelvis shape and go to Mesh->Separate.In the Outliner we can see that the node that was the 
Pelvis  shape  has  been changed to  a  group node with  the  same name.It  contains  several 
smaller shape nodes which you can select and see what they represent.Then you can select all 
those that really make up the pelvis section of Ryan.Also there is the Accessories shape that 
we want to make so it's the perfect time to.Basically the Accessories shape consists of the 
belt,the belt loops and the pocket flaps of the pants.Now,it can consist of anything else that is  
difficult to deal with when skinning.Typically they are parts of geometry that are on top of 
another geometry and have to move with the underlying geometry just like a belt moves with 
the pants.So we select only the parts that complete the rest of the geometry of the pants and 
name that Pelvis.Then we select the belt and the belt loops and combine them into a new 
shape and take the leftover part of the blouse and combine&merge it following the steps we 
talked about earlier to complete the torso.We will also add the leg pockets' flaps too in the 
Accessories shape.It's the same thing as with the Pelvis shape.Separate to find the smaller 
parts and select those we need and recombine them into new ones.
Of course we also have to account for human error and try to fix it.For example in Ryan there 
were some stray vertices or extra ones.With extra vertices we can delete them.If they don't  
connect with other vertices the Del key suffices but when we have connections we have to 
use EditMesh->Delete Edge/Vertex.Now would be a good time to scale the model into our 
desired magnitude before the rigging and as  always  freeze  transformations  at  the  end to 
solidify the changes as if the model was created like this.This completes the preparation for 
Ryan's geometry.



Appendix B:Create the Skeleton and it's orientation

Open the file containing the geometry and save as Ryan_Skeleton.ma.We go into side 
view(with SPACE pressed on left click on Maya and drag to the side view button) and start 
by putting the leg joints in place.Earlier we said that placement comes first and orientation 
after,but Maya can do both during placement with the right settings.We go to Skeleton->Joint 
Tool[].At the left side of the screen we can see the options for the joint tool.There we change 
the orientation to the one we think is best and in this case YXZ.Then we start placing the leg's 
joints.It's possible that we might move the joints which will invalidate that orientation we 
chose.In that case we make the moves we want and select a joint higher up the chain and 
reorient(we'll talk about it in detail in a bit).The recommended workflow for building the 
skeleton would be to first create the left leg chain and mirror across the X axis to create the  
right leg,then the torso starting from the root going up towards the neck,then the left arm and 
then the right arm by mirroring the left on the X axis.The head can be done later.It's easier 
though to create those joint chains separately and leave them disconnected until after their 
individual orientations are done.For example we know that in the H-anim standard the left 
hip  joint  will  be  parented  to  the  sacroilliac  joint.However  we  parent  them after  having 
oriented the joint chain of the left leg which starts at the left hip joint.Back to the joint ,for the 
purpose of a Reverse Foot Lock the subtalar and midtarsal joints were skipped since they 
ruined the RFL movement,which is not a problem since they are just skipped and not replaced 
with other non-H-anim joints.RFL is a "battle"-tested system of joints and one control placed 
in specific points,controlling the foot joints giving enough control over the animation of the 
Leg and the Foot to the animator to make his work much easier.For the same purpose a new 
joint called toe is added at the very end of the hierarchy as a child of the metatarsal joint.So 
the joint chain for the legs is:hip->knee->ankle->metatarsal->toe.After placing all 5 joints we 
press Enter to declare we are now finished with joint creation.These joints are created along 
the  X=0 axis.So we change back to  the  perspective  view the  same way we got  to  side 
view.We move the joints around to align them with the geometry(let's say the left leg) and at 
the end we select all joints and freeze transformations.That will only zero out the rotations 
but that's exactly what we want.It's not desirable to have rotations in joints.Then we go in the  
Outliner(Window->Outliner) and rename the joints with a "l_" prefix.To create the right leg 
we select the l_hip joint and go to Skeleton->Mirror Joint[].Since we want to mirror across 
the X axis we select the YZ plane with Behaviour as the Mirror Function and fill the Replace 
text area with "l_" and the With text area with "r_".This is going to create the right leg's joints 
as an exact mirrored copy of the left leg joints with an "r_" prefix.The steps so far are enough 
to give you some insight as to how to create the rest of the body.

Although the rest of the body joints are created the same way without any need to 
stray from H-anim the face is a bit different.There's so much facial animation one can do with 
just on eye joint,one eyelid joint ,one eyebrow joint and another one that is at the center of the 
head as H-anim instructs.We are lucky though that there is a way to add joints while staying 
true to H-anim.Digital-Tutors has some very instructive videos concerning joint based facial 
animation.The facial rig that was the result of modifying the the one DT proposed while still 
obeying H-anim was the one shown in the images in section 3.1.There is one thing though 
that  cannot  show  in  the  figures.The  two  lower_eyelid_base  joints  need  to  be  oriented 
differently.That's  because  the  lower eyelids  move upwards  when the upper  eyelids  move 
downwards.If we selected both the upper and lower eyelid base joints and tried to rotate them 
together in the Z axis they would rotate both either upwards or downwards.To make it easier 
for us we will "reorient" the lower eyelid base joints so that rotating both eyelid base joints in 
the Z axis will rotate them differently and not in the same direction.The reason it's easier for 
us is that we can just link the rotate Z attribute of both eyelid base joints into one blink 



attribute thus by using that attribute we can blink the eye,leave it open,half open and so on.To 
do that,we select the lower_eyelid_base joint and rotate it 180 degrees in the Y axis and 
freeze transformations.If we check the Local Rotation Axes now it should be a 180 degree 
rotated  version  of  the  upper_eyelid_base  joint's  Local  Rotation  Axes.Selecting  both 
eyelid_base joints and rotating in the Z axis will show you a blink movement.

After  creating  all  the  joints  we  select  all  of  them  by  select  HumanoidRoot  and 
executing  the  MEL command  'select  -hi;',then  we  freeze  transformations  to  remove  any 
rotations.

If  you  check  out  their  local  rotation  axes  they're  inconsistent.To  fix  this,select 
HumanoidRoot and go to Skeleton->Orient Joint[].We check YXZ,leave the rest as is and it 
should orient  all  non-leaf  joints  correctly.If  there is  any kind  of  warning about  non-zero 
transforms usually even if seemingly the rotations are zero they might be -0 or appear to be 0 
when  it  hasn't  been  set  properly.In  that  case  we  check  the  joint  through  the  Attribute 
Editor(Ctrl+A) and zero out all rotation values manually.Sometimes there are just too many 
joints  to  fix  each  one  manually  so  we  have  prepared  a  script  for  such  an  occasion(see 
Appendix C) and we reorient as instructed above after we have ran it.We are not finished 
yet.When we orient joints it's always the leaf joints that get oriented differently and in some 
cases not at all.So we select all leaf joints and go to Skeleton->Orient Joint[] but this time we  
check None for the orientation scheme.This tells the joints to get the same orientation as their 
parent joints.Again,select all joints and freeze transformations to solidify the skeleton.
At this point I would recommend you create a visibility layer called joints and add all the 
joints in it(See Additional Instructions).



Appendix C:Creating the ikHandles for Ryan

On to creating the ikHandles,load Ryan_Skeleton.ma and save as Ryan_Rig.ma in 
order to avoid having to rename things to get rid of the namespaces importing creates and 
also because well ikHandles need to be created upon joints.Create a visibility layer called 
dont_touch.We will fill it  with all those things we don't want others to mess with(namely 
animators) and it also serves as a place to put things we don't want in the way while working.
After creating the ikHandles and connecting them to controls we don't have any use for the 
actual handles so it's better to have them in a visibility layer that's gonna be set to invisible.

In this project we will be using RP(Rotate Plane) ikHandles for the eyes,the neck,the 
legs and the parts above the shoulderblades, SC(Single Chain) ikHandles for the foot joints 
and a Spline ikHandle for the spine.Creating a RP or SC ikHandle is very simple.We go to  
Skeleton->IK  Handle  Tool[]  and  with  the  default  settings  choose  either  ikRPsolver  or 
ikSCsolver in the Current solver dropbox,then left click on the starting joint,left click on the 
ending joint and the handle is created and shown in the viewport.

We will first create the Spline ikHandle for the spine.The reason is it might mess the 
joint placement for the spinal joints.The Spline ikHandle creates a curve that goes through the 
spinal joint chain,but unfortunately it can't handle extreme S-shaped curvatures.Actually there 
are settings for it but it won't have the same effect and motion like we want it to(it adds too 
many control vertices and even if we select many of them the motion is not natural).We want 
it to have as many as four CVs at most,including the two edge CVs that go on the first and 
last joint of the spine.To find out if the spine needs fixing we will create the spline ikHandle 
and see if the curvature changes or if there are rotations in the spinal joints.If there we must 
correct them.

We go to Skeleton->IK Spline Handle Tool[].With the default settings we choose vl5 
first and vc6 and the handle is created.If the spinal joints get transformed in any way(check 
joint rotations) then freeze transformations and reorient from HumanoidRoot.Selecting the 
ikHandle,rename it  to  ikHandle_spline_spine.Like we talked about  above,select  the curve 
from the viewport or alternatively from the outliner,it's parented under the HumanoidRoot 
joint  and  it's  called  curve1.Go  into  component  mode(F8).You  can  see  the  curve's 
vertices(CV) now,selecting and moving anyone of them will get you the desired effect.Before 
going further we need to check the edge vertices are snapped(see Aditional Instructions) on 
the appropriate joints.The vertex near vl5 should be ok but almost always the one near the 
end-effector is not,and true enough if you check the vertex near vc6 you will see it's  not 
snapped on vc6.To correct that,select the vertex,with the V key pressed,press and drag the 
middle  mouse  button  slighlt  around  vc6  and  check  from  different  angles  it  is  snapped 
correctly.In order to move those vertices in object mode we will use Cluster Deformers.This 
feature is just what the name suggests.We select vertices and group them in one cluster node 
so that when we move the cluster in object mode those vertices follow.Selecting each vertex 
of the spline curve we go to Create Deformers->Cluster[].It is very important to have the 
relative option checked otherwise things won't move the way we want them to,something that 
applies to any cluster used in this project.You can see now a small C shape.Since selecting it 
in component mode is impossible we return to object mode(F8 again) and select it there.You 
can confirm the effect by moving it around.But there is one small problem.The cluster shape 
has been created too close to the vertex so it will be difficult to always zoom to be able to 
select it from the viewport.Thus we select it once,hit Ctrl+A to get to the Attribute Editor and 
in the clusterXXHandleShape tab we change the origin value for the rightmost box which is 
the Z axis by having Ctrl and Left Click pressed and dragging left or right.Move the Cluster 
symbol to the back part of the mesh.Do the same for the other three vertices.

For the leg we will create a RP ikHandle starting from the hip and ending at the ankle 



which we will name ikHandle_l/r_leg depending on the side.For the foot we will create two 
SC ikHandles,from the ankle to the metatarsal and from the metatarsal to the toe and the 
naming will be ikHandle_SC_l/r_foot and ikHandle_SC_l/r_toe respectively.In this project 
we followed the convention that apart from the spline for the spine any ikHandle that doesnt 
have the solver in the name is a RP ikHandle and the rest that are Single Chain have SC in the 
name.Having said that only four SC ikHandles exist,and all four have to do with the feet and 
toes.The reason we use a RP for the legs and SC for the feet is that we want to be able to  
control the orientation of the joints separately in a knee control.Something that isn't needed in 
the feet and toes.

For the arms,we just need one RP ikHandle per side starting from the shoulder and 
ending at the wrist joint.The name should be ikHandle_l/r_wrist.

We will add ikHandles around the trapezius muscle in both sides where the specified 
region can rotate backward and foreward in reality.Since we want to control the orientation of 
the joints we will use RP solvers.These handles will start at the sternoclavicular joint and end 
at the shoulder joint and will be called ikHandle_l/r_clavicle.

We also have the neck ikHandle to create.A simple RP ikHandle from vc6 to vc1 will 
do,called ikHandle_neck.Both RP and SC can do the job but RP doesn't allow rotation at the 
end joint so it's perfect.

Last but not least we have the two eyes to take care of.We will create two simple RP 
ikHandles,one in each eye,from the eyeball joint to the eyeball_tip joint.These two don't have 
the same reason to exist  as the previous handles.They just  make it  easier to  animate the 
eyes.We don't have to mess with rotations,we just make the handles,parent them to controls 
and  move  the  controls  around  so  that  the  eyes  follow.Their  names  will  be 
ikHandle_l/r_eyeball.

Now in the Outliner grab all ikHandle nodes and parent them to ikHandlesGRP.The 
Spine_spline curve along with it's clusters go under the HumanoidRoot node.



Appendix D:Creating the Controls for Ryan 

To create the controls though we need the geometry because some of the controls need 
to be a bit bigger than the outline of the body parts they are meant to control.

Feet Controls:
*Create->NURBS Primitives->Circle.Click and drag somewhere in the ground to create the 
shape.By default it will be created with 8 sections(basically edges but it also happens to be 
the number of the vertices too).You can also used the MEL code in Appendix E.
*Rename the circle to l_footControl.
*Go into the Move tool and snap the circle to the l_metatarsal or the l_RLFoot joints.To do 
this go into the Move tool and with the V key pressed,press the middle mouse button and 
drag a bit near the joint you want to target.
*Go into component mode(F8),go into the move tool and move the vertices around to form 
an outline of the foot.
*Go back to object mode(F8 again).
*To create the right foot control select l_footControl and duplicate(Ctrl+D).
*With the duplicated control,group(Ctrl+G) and set ScaleX to -1.You'll see the duplicated 
control on the other side,properly rotated.(It's a good trick to mirror things across the X axis).
*Ungroup.This command does not have a shortcut so go to Edit->Ungroup.
*Rename the right foot control to r_footControl.
*To be sure go to the move tool and snap r_footControl to r_metatarsal or r_RLFoot to check 
it's in the right coordinations.
*Finally  select  both  feet  controls  and  freeze  transformations(Modify-
>FreezeTransformations)

Knee Controls:
*For the knee controls we create letter shapes.For the left side we will create a shape for the 
letter l(lowcase).Go to Create->Text[].
*Write l as text and leave the rest as is,and press Create.
*Ungroup twice(Edit->Ungroup) to get the curve and get rid of useless groups.
*Rename it to l_kneeControl.
*Center it's pivot(Modify->Center Pivot)
*Now that the l shape is created ,snap it with the usual way to the l_knee joint.
*Scale it down to your preferred size.
*Move it away from the model on the Z axis after selecting the move tool,we would like a 
fair distance from the knee because we want to implement a knee lock for the control to  
follow the movement of the leg and we don't want it to go inside the geometry in some near  
extreme transforms.
*Do all previous steps for the right side,using the letter r this time.
*Select both knee controls and freeze transformations.

Hip Controls:
We have two hip controls.One is the main hip control and the other is the hip sway

control.The  main  hip  control  moves  the  following controls:  hipSwayControl,  absControl, 
chestControl,backControl and neckControl.The hipSway only controls the sway in the hips 
but does not affect the rest.

hipControl:
*Create a cube as instructed in Appendix E.
*Rename the cube to hipControl.



*Select the move tool and snap the cube to the HumanoidRoot joint.
*Go into component mode and move the vertices around (again after selecting the  
move tool) in order for the cube to follow the outline and curvature of the hips.
*When finished go back to object mode and freeze transformations.

hipSwayControl:
*Create a circle as instructed in Appendix E.
*Rename the circle to hipSwayControl.
*Select the move tool and snap the control to the HumanoidRoot joint.
*Go into component mode and select every other vertex.If,say,vertex 0 is the one  
directly in  front of the HumanoidRoot joint along the Z axis then select  vertices  
1,3,5,7.
*Select the scale tool and scale from the pivot inwards so that the selected vertices 
move towards the HumanoidRoot joint creating a star shape in the process.
*When finished go back to object mode and freeze transformations.

Abs Control:
*Create a circle as instructed in Appendix E..
*Rename it to absControl
*Select the control,then select the move tool and snap it to the vt12 joint.
*Scale up if necessary(ie if the radius is smaller than the geometry's cross section with the 
control)
*If  it's  visually  better,go  into  component  mode,select  all  vertices  and  move  downwards 
slightly.
*Go back to object mode and freeze transformations.

Chest Control:
*Like the hipControl create a cube as instructed in Appendix E.
*Rename the cube to chestControl.
*Select the move tool and snap the cube to the vt5 joint.
*Again go into component mode and move the vertices around to follow the curvature of the 
chest and it's volume/outline.
*Go back to object mode and freeze transformations.

Neck Control:
*Create a circle as instructed in Appendix E..
*Rename it to neckControl
*Select the control,then select the move tool and snap it to the vc1 joint.
*Scale up if necessary(ie if the radius is smaller than the geometry's cross section with the 
control)
*Rotate the control a bit for the control and the neck to be parallel.
*Freeze transformations.

Back Control:
*To create the control used in this project(an double arrow) we use the snap to grid feature.
*Go to side view.
*You can see in the upper middle section of Maya five icons with a magnet.These are the 
snap modes.By default we snap to points,but what we want is to snap to grids.With the V key 
pressed,uncheck the snap to points mode(third icon) and check the snap to grids mode(first 
mode).



*Go to Create->CV Curve Tool[] and check linear curve degree.
*Again with V pressed,we click on grid vertices to form an arrow(last vertex goes on top of 
the first to terminate the shape)
*Press Enter to create the shape node.
*Rename curve to backControl.
*Modify->Center Pivot
*Select the control,then select the move tool and snap it to the vc6 joint.
*Go into component mode and select all vertices
*Move them to the desired place
*Go back in object mode
*Freeze transformations.
*Just  to  make things  easier  for  next  time you use the move tool  to  snap,press  and hold 
V,unclick the first snap mode box(snap to grid) and click on the third snap mode box(snap to 
point)

Clavicle/Shoulder Controls:
*For the elbow controls we create letter shapes.For the both sides we will create shapes for 
the letter s(lowcase).Go to Create->Text[].
*Write s as text and leave the rest as is,and press Create.
*Ungroup twice(Edit->Ungroup) to get the curve and get rid of useless groups.
*Rename it to l_shoulderControl.
*Center it's pivot(Modify->Center Pivot)
*Now that the s shape is created ,snap it with the usual way to the l_shoulder joint.
*Scale it down to your preferred size.
*Go into component mode,select all of the control's vertices and move them up and away 
from the model on the Y axis after selecting the move tool.
*For the right side simply duplicate the left shoulder control
*Rename it to r_shoulderControl.
*Select the move tool and snap it to the r_shoulder joint.
*Select both shoulder controls and freeze transformations.

Elbow Controls:
*For the elbow controls we create letter shapes.For the left side we will create a shape for the 
letter l(lowcase).Go to Create->Text[].
*Write l as text and leave the rest as is,and press Create.
*Ungroup twice(Edit->Ungroup) to get the curve and get rid of useless groups.
*Rename it to l_elbowControl.
*Center it's pivot(Modify->Center Pivot)
*Now that the l shape is created ,snap it with the usual way to the l_elbow joint.
*Scale it down to your preferred size.
*Move it away from the model on the Z axis after selecting the move tool,we would like a 
fair distance from the elbow because we want to implement an elbow lock for the control to 
follow the movement of the arm and we don't want it to go inside the geometry in some near 
extreme transforms.
*Do all previous steps for the right side,using the letter r this time.
*Select both elbow controls and freeze transformations.

Wrist Controls:
*Create a cube as instructed in Appendix E.
*Rename the cube to l_wristControl.



*Select the move tool and snap the cube to the l_wrist joint.
*Rotate and scale the control if necessary.
*Do all the above steps again for the r_wristControl(right wrist)
*Select both l_wristControl and r_wristControl and freeze transformations.

Lip Controls:
*Create a circle as instructed in Appendix E..
*Rename the circle to l_upperlipControl.
*Select the move tool and snap it to the l_upperlip joint.
*Rotate it 90 degrees in the X axis by entering 90 as the value of it's Rotate X attribute
*Scale it down so much that the circle's diameter is just a bit longer than the lip area.
*Into component mode grab all of the control's vertices and move them in front of the face 
along the Z axis as much as you think it takes for the control to be easily clickable/accessible.
*Back to object mode,freeze transformations.

-Follow the steps below for each of the remaining lip joints/controls:
*Select l_upperlipControl(you can also use the previously made lip control)
*Duplicate(Ctrl+D)
*Select the move tool and snap it to the next lip joint(ie the c_upperlip).
You can see the pivot rests on top of the joint we snapped onto but the shape remains in the 
distance(when we moved the vertices away).
*Rename the control to c_upperlipControl(since we used the c_upperlip joint)
*Freeze transformations(you can leave this one out in each iteration and select all lip controls 
in the end and perform it once).

Eyebrow Controls:
Exactly the same as the lip controls
*Create a circle as instructed in Appendix E..
*Rename the circle to l_eyebrow01Control.
*Select the move tool and snap it to the l_eyebrow01 joint.
*Rotate it 90 degrees in the X axis by entering 90 as the value of it's Rotate X attribute
*Scale it down so much that the circle's diameter is just a bit longer than the eyebrow area.
*Into component mode grab all of the control's vertices and move them in front of the face 
along the Z axis as much as you think it takes for the control to be easily clickable/accessible.
*Back to object mode,freeze transformations.

-Follow the steps below for each of the remaining lip joints/controls:
*Select l_eyebrow01Control(you can also use the previously made eyebrow control)
*Duplicate(Ctrl+D)
*Select the move tool and snap it to the next eyebrow joint(ie the l_eyebrow02).
You can see the pivot rests on top of the joint we snapped onto but the shape remains in the 
distance(when we moved the vertices away).
*Rename the control to l_eyebrow02Control(since we used the l_eyebrow02 joint)
*Freeze transformations(you can leave this one out in each iteration and select all eyebrow 
controls in the end and perform it once).

Nose Controls:
*Go to front view and then Create->CV Curve Tool[].Select linear curve degree.
*Press and hold V and change the snap mode to snap-to-grid(first box).
*Still  holding  V pressed,click  on  the  grid  to  snap  on  grid  intersections  and  create  two 



adjoining squares.Press Enter at the end to confirm the curve is finished.
*Just  to  make things  easier  for  next  time you use the move tool  to  snap,press  and hold 
V,unclick the first snap mode box(snap to grid) and click on the third snap mode box(snap to 
point)
*Select the curve and rename the curve to mainNoseControl
*Center it's pivot(Modify->Center Pivot)
*Select the move tool and snap the control to the nose_tip joint.
*Into component mode,select all vertices and move them in front of the nose geometry and 
move them accordingly to make sure they follow the curvature of the nose geometry's tip.
*Back to object mode,duplicate the control twice.
*Select one duplicate control,select the move tool and snap it to the l_nostril_base joint,select 
the other duplicate control and snap it to the r_nostril_base joint.
*Rename the duplicate controls to l_nostrilControl and r_nostrilControl respectively.
*Select the l_nostrilControl and set the RotateY attribute to 90,set the RotateY attribute of 
r_nostrilControl to -90 instead.You can see now that we have the controls in the right sides.
*If need be select the controls,go in compoment mode and move the vertices around 
in order for the control and it's position visually to look right and scale them as much as you 
think is right.
*In the end select all three controls and freeze transformations.

Jaw Control:
Exactly like mainNoseControl
*Go to front view and then Create->CV Curve Tool[].Select linear curve degree.
*Press and hold V and change the snap mode to snap-to-grid(first box).
*Still  holding  V pressed,click  on  the  grid  to  snap  on  grid  intersections  and  create  two 
adjoining squares.Press Enter at the end to confirm the curve is finished.
*Just  to  make things  easier  for  next  time you use the move tool  to  snap,press  and hold 
V,unclick the first snap mode box(snap to grid) and click on the third snap mode box(snap to 
point)
*Select the curve and rename the curve to lowerJawControl
*Center it's pivot(Modify->Center Pivot)
*Select the move tool and snap the control to the lowerJaw_Pivot joint.
*Into component mode,select all  vertices and move them in front of the chin part  of the 
geometry and move them accordingly to make sure they follow the curvature of the chin.
*Back to object mode,select the scale tool and scale the control as much as you think makes 
sense and freeze transformations.

Tongue Controls:
*Create a cube as instructed in Appendix E.
*Rename the cube to tongueBaseControl.
*Select the move tool and snap the cube to the tongueBaseA joint.
*Scale the control if necessary.
*In component mode,select all vertices and move upwards on the Y axis to make it accessible 
and go back to object mode
*Create a cube as instructed in Appendix E.
*Rename the cube to tongueCentreBackControl.
*Select the move tool and snap the cube to the tongueCenterBackA joint.
*Scale the control if necessary.
*In component mode,select all vertices and move upwards on the Y axis to make it accessible 
and go back to object mode
*Create a cube as instructed in Appendix E.



*Rename the cube to tongueCenterControl.
*Select the move tool and snap the cube to the tongueCenterA joint.
*Scale the control if necessary.
*In component mode,select all vertices and move upwards on the Y axis to make it accessible 
and go back to object mode
*Create a cube as instructed in Appendix E.
*Rename the cube to tongueCenterFrontControl.
*Select the move tool and snap the cube to the tongueCenterFrontA joint.
*Scale the control if necessary.
*In component mode,select all vertices and move upwards on the Y axis to make it accessible 
and go back to object mode
*Select  tongueBaseControl,tongueCenterBackControl,tongueCenterControl  and 
tongueCenterFrontControl and freeze transformations.

Eye Controls:
*Go to front view and then Create->CV Curve Tool[].Select linear curve degree.
*Press and hold V and change the snap mode to snap-to-grid(first box).
*Still  holding  V  pressed,click  on  the  grid  to  snap  on  grid  intersections  and  create  a 
cross.Press Enter at the end to confirm the curve is finished.
*Repeat the above to create a square as big as the cross.
*Just  to  make things  easier  for  next  time you use the move tool  to  snap,press  and hold 
V,unclick the first snap mode box(snap to grid) and click on the third snap mode box(snap to 
point).
*Duplicate the cross.
*Rename  the  crosses  to  l_eyeControl  and  r_eyeControl  respectively  and  the  square  to 
mainEyeControl.
*Select each of the three controls and center it's pivot.
*Select the move tool,snap l_eyeControl to the l_eyeball_tip joint and r_eyeControl to 
the r_eyeball_tip joint.
*Select mainEyeControl and set TranslateY and TranslateZ with the same values as in the left  
and right  eye controls.In the end it  should be exactly in the middle between the the eye 
controls.
*Select  all  three  controls  and  move  them along  the  Z  axis  to  be  in  front  of  the  face's 
geometry.
*Finally freeze all three controls' transformations.
Head Rotation Control:
*Create a joint shaped curve as instructed in Appendix E.
*Rename the curve to headRotationControl
*Select the move tool and snap it to the skullbase joint
*Into component mode,select all it's vertices and move them upwards on the Y axis as much 
as is needed for the control to be above the head geometry.
*Back in object mode,freeze transformations

Head Back Marker:
*Create a joint shaped curve as instructed in Appendix E.
*Rename the curve to headBackMarker
*Select the move tool and snap it to the head_back_Pivot joint
*Into component mode,select all it's vertices and move them outwards on the Z axis as much 
as is needed for the control to be behind the head geometry.



*Back in object mode,freeze transformations

Global Control:
*Create a circle as instructed in Appendix E.Set the sections variable to 16 and leave the rest 
as is.
*Rename the circle to globalControl.
*Select the move tool and snap the control to the HumanoidRoot joint.
*Move the control to the ground.
*Go into component mode and select every other vertex.If,say,vertex 0 is the one directly in 
front of the HumanoidRoot joint along the Z axis then select vertices 1,3,5,7,9,11,13,15.
*Select the scale tool and scale from the pivot inwards so that the selected vertices 
move towards the center of the circle.
*When finished go back to object mode and freeze transformations.



Appendix E:Creating Ryan's Structure

To create a group,simply hit Ctrl+G either with nothing selected to create an empty 
group or with something selected to create a group with the selection list as it's children. 

cl_neckGRP:
*Select the cl_neck cluster
*Group it(Ctrl+G)
*Rename group to cl_neckGRP

cl_chestGRP:
*Select the cl_chest cluster
*Group it(Ctrl+G)
*Rename group to cl_chestGRP

cl_absGRP:
*Select the cl_abs cluster
*Group it(Ctrl+G)
*Rename group to cl_absGRP

cl_hipsGRP:
*Select the cl_hips cluster
*Group it(Ctrl+G)
*Rename group to cl_hipsGRP

JointsGRP:
*Select HumanoidRoot,cl_neckGRP,cl_chestGRP,cl_absGRP and cl_hipsGRP
*Create a group with Ctrl+G
*Rename the new group to JointsGRP

l_kneeControlGRP:
*Select the l_kneeControl
*Create a group with Ctrl+G
*Rename the new group to l_kneeControlGRP

r_kneeControlGRP:
*Select the r_kneeControl
*Create a group with Ctrl+G
*Rename the new group to r_kneeControlGRP

LowerBodyControlsGRP:
*Select  l_kneeControlGRP,  r_kneeControlGRP,  l_RLBase,  r_RLBase,  l_footControl, 
r_footControl
*Group them with Ctrl+G
*Rename the new group to LowerBodyControlsGRP

l_wristControlGRP:
*Select the l_wristControl



*Create a group with Ctrl+G
*Rename the new group to l_wristControlGRP

r_wristControlGRP:
*Select the r_wristControl
*Create a group with Ctrl+G
*Rename the new group to r_wristControlGRP

l_elbowControlGRP:
*Select the l_elbowControl
*Create a group with Ctrl+G
*Rename the new group to l_elbowControlGRP

r_elbowControlGRP:
*Select the r_elbowControl
*Create a group with Ctrl+G
*Rename the new group to r_elbowControlGRP

clavicleControlsGRP:
*Select the l_shoulderControl and the r_shoulderControl
*Create a group with Ctrl+G
*Rename the new group to clavicleControlsGRP

neckControlGRP:
*Select the neckControl
*Create a group with Ctrl+G
*Rename the new group to neckControlGRP

UpperBodyControlsGRP:
*Select  l_wristControlGRP,  r_wristControlGRP,  l_elbowControlGRP,  r_elbowControlGRP, 
clavicleControlsGRP,neckControlGRP,hipControl,hipSwayControl,backControl,absControl 
and chestControl
*Create a group with Ctrl+G
*Rename the new group to UpperBodyControlsGRP

bodyControlsGRP:
*Select UpperBodyControlsGRP and LowerBodyControlsGRP
*Create a group with Ctrl+G
*Rename the new group to bodyControlsGRP

l_brow_controlGRP:
*Select all left eyebrow controls:l_eyebrow01Control to l_eyebrow04Control
*Create a group with Ctrl+G
*Rename the new group to l_eyebrow_controlGRP

r_brow_controlGRP:
*Select all right eyebrow controls:r_eyebrow01Control to r_eyebrow04Control
*Create a group with Ctrl+G
*Rename the new group to r_eyebrow_controlGRP

eyebrowControlsGRP:



*Select l_brow_control_GRP and r_brow_control_GRP
*Create a group with Ctrl+G
*Rename the new group to eyebrowControlsGRP

noseControlsGRP:
*Select mainNoseControl,l_nostrilControl and r_nostrilControl
*Create a group with Ctrl+G
*Rename the new group to noseControlsGRP

upperLip_controlGRP:
*Select all upper lip controls:l_upperLipControl,c_upperLipControl and r_upperLipControl
*Create a group with Ctrl+G
*Rename the new group to upperLip_controlGRP

lowerLip_controlGRP:
*Select  all  lower  lip  controls:l_lowerLipControl,  c_lowerLipControl,  r_lowerLipControl, 
l_lipCornerControl and r_lipCornerControl
*Create a group with Ctrl+G
*Rename the new group to lowerLip_controlGRP

lipControlsGRP:
*Select upperLip_controlGRP and lowerLip_controlGRP
*Create a group with Ctrl+G
*Rename the new group to lipControlsGRP

eyesAimGRP:
*Select l_eyeControl and r_eyeControl
*Create a group with Ctrl+G
*Rename the new group to eyesAimGRP

eyeControlsGRP:
*Select mainEyeControl and eyesAimGRP
*Create a group with Ctrl+G
*Rename the new group to eyeControlsGRP

lowerJawControlGRP:
*Select lowerJawControl,tongueBaseControl,tongueCenterBackControl,tongueCenterControl 
and tongueCenterFrontControl
*Create a group with Ctrl+G
*Rename the new group to lowerJawControlGRP

HeadRotationControlGRP:
*Select headRotationControl
*Create a group with Ctrl+G
*Rename the new group to headRotationControlGRP

faceControlsGRP:
*Select eyebrowControlsGRP,noseControlsGRP,lipControlsGRP,eyeControlsGRP,
lowerJawControlGRP,HeadRotationControlGRP and the headBackMarker control
*Create a group with Ctrl+G



*Rename the new group to faceControlsGRP

ikHandlesGRP:
*Select all ikHandles in the Outliner
*Create a group with Ctrl+G
*Rename the new group to ikHandlesGRP

ControlsGRP:
*Select the following GRPs:bodyControlsGRP,faceControlsGRP and ikHandlesGRP
*Create a group with Ctrl+G
*Rename the new group to ControlsGRP

EyesGRP:
*Select the l_eyeball and r_eyeball meshes
*Create a group with Ctrl+G
*Rename the new group to EyesGRP

TeethGRP:
*Select the topteeth and bttmteeth meshes
*Create a group with Ctrl+G
*Rename the new group to TeethGRP

TongueGRP:
*Select the tongue mesh
*Create a group with Ctrl+G
*Rename the new group to TongueGRP

GeometryGRP:
*Select  EyeGRP,TeethGRP  and  TongueGRP  and  the  following 
meshes:Face,Left_arm,Right_arm,Torso,Legs and Accessories
*Create a group with Ctrl+G
*Rename the new group to GeometryGRP

Ryan_Anatomy:
*Select JointsGRP,ControlsGRP,GeometryGRP and the globalControl
*Create a group with Ctrl+G
*Rename the new group to Ryan_Anatomy

Now that we have everything in the appropriate groups it's time to complete the parent 
relationships(parent constraints are to be created in the Constraints section).The logic behind 
when to use parenting and when to use parent constraints is that if you want the children 
nodes to be able to move independently as well as move the same ammount as the parent you  
have to parent.If you want the children of this relationship to follow the parent blindly then 
we have to parent constraint.

That said,let's parent:

JointsGRP:
We want the clusters to move along with the spine_spline curve,because they control the 
curve's vertices.But we also want them to be able to move independently and we have created 
controls for that.That's why we grouped each cluster separately.So we just parent the groups 



under the HumanoidRoot and we achieve both behaviours.
*Parent cl_hips under HumanoidRoot
*Parent cl_abs under HumanoidRoot
*Parent cl_chest under HumanoidRoot
*Parent cl_neck under HumanoidRoot

ControlsGRP:
bodyControlsGRP:

LowerBodyControlsGRP:
In this group we have to parent the RL base joints to the feet controls.The way 

it's supposed to work is,the control in question controls the translations of the foot and the 
joint based control that is represented by the RLBase joint hierarchy provides the rotations for 
it.

*Parent l_RLBase under l_footControl
*Parent r_RLBase under r_footControl

UpperBodyControlsGRP:
I chose to parent the upper body controls in a way that the back control drags 

along with it the shoulder controls and the neck control,and the hip control controls all the 
above controls along the torso including the neck and shoulders.You might want different 
behaviours,ie instead of a hip way and a hip control we could have just one,responsible only 
for  the  hip  movement  and totally unrelated to  the above.The reason we created  that  hip 
control is that when animating a walk we can just use the hip control to move the rest of the  
controls ,from the hip upwards,with it instead of moving each of them to the appropriate 
position. 

*Parent clavicleControlsGRP,neckControlGRP under backControl
*Parent  backControl,chestControl,absControl  and  hipSwayControl  under  
hipControl

faceControlsGRP:
lowerJawControlGRP:
This group contains five controls:four controls for the tongue and one control 

for the lower jaw.It's safe to say that the tongue moves as the jaw moves,therefore the tongue 
controls follow the jaw control.The tongue controls are parented in a way that each control is 
parented under the adjacent control as long as that control is nearer to the tongue base,ie the 
tongueCenterFrontControl  which  is  next  to  the  tongue  tip  has  to  be  parented  under  the 
tongueCenterControl  since  that  control  is  nearer  to  the  tongue  base  than 
tongueCenterFrontControl.

*Parent tongueCenterFrontControl under tongueCenterControl
*Parent tongueCenterControl under tongueCenterBackControl
*Parent tongueCenterBackControl under tongueBaseControl
*Parent tongueBaseControl under lowerJawControl

eyeControlsGRP:
This group contains the main eye control and the eyesAimGRP which holds 

the individual eye controls.It's obvious enough that we are going to parent the group holding 
the individual eye controls under the main eye control in order to move both eye controls  
when moving the main eye control.

*Parent eyesAimGRP under mainEyeControl



noseControlsGRP:
This group contains the main nose control and two nostril controls.Again it's 

pretty obvious that we are going to parent the nostril controls under the main nose control.
*Parent l_nostrilControl and r_nostrilControl under mainNoseControl



Appendix F:Creating Ryan's Locators

Let's create all the locators we are going to need:
Humanoid Root joint:
*Create a locator(Create->Locator)
*Rename it to locPar_HumanoidRoot
*Select the locator
*Select  the  HumanoidRoot  joint(either  with  shift  selection  from the  viewport  or  by Ctrl 
Selection through the Outliner)
*Use matchTransformsTool
*Parent the locator under the hipSwayControl

Left Wrist joint:
*Create a locator(Create->Locator)
*Rename it to locOri_l_wrist
*Select the locator
*Select the l_wrist joint(either with shift selection from the viewport or by Ctrl Selection 
through the Outliner)
*Use matchTransformsTool
*Parent the locator under the l_wristControl

Right Wrist joint:
*Create a locator(Create->Locator)
*Rename it to locOri_r_wrist
*Select the locator
*Select the r_wrist joint(either with shift selection from the viewport or by Ctrl Selection 
through the Outliner)
*Use matchTransformsTool
*Parent the locator under the r_wristControl

Vc1 joint:
*Create a locator(Create->Locator)
*Rename it to locOri_vc1
*Select the locator
*Select the vc1 joint(either with shift selection from the viewport or by Ctrl Selection through 
the Outliner)
*Use matchTransformsTool
*Parent the locator under the neckControl

Skullbase joint:
*Create a locator(Create->Locator)
*Rename it to locOri_skullbase
*Select the locator
*Select the skullbase joint(either with shift selection from the viewport or by Ctrl Selection 
through the Outliner)
*Use matchTransformsTool
*Parent the locator under the headRotationControl

Lower Jaw Pivot joint:
*Create a locator(Create->Locator)



*Rename it to locOri_lowerJaw_Pivot
*Select the locator
*Select  the lowerJaw_Pivot  joint(either  with shift  selection from the viewport  or by Ctrl 
Selection through the Outliner)
*Use matchTransformsTool
*Parent the locator under the lowerJawControl

Tongue Base A joint:
*Create a locator(Create->Locator)
*Rename it to locPar_tongueBaseA
*Select the locator
*Select  the  tongueBaseA joint(either  with  shift  selection  from  the  viewport  or  by  Ctrl 
Selection through the Outliner)
*Use matchTransformsTool
*Parent the locator under the tongueBaseControl

Tongue Center Back A joint:
*Create a locator(Create->Locator)
*Rename it to locPar_tongueCenterBackA
*Select the locator
*Select the tongueCenterBackA joint(either with shift selection from the viewport or by Ctrl  
Selection through the Outliner)
*Use matchTransformsTool
*Parent the locator under the tongueCenterBackControl

Tongue Center A joint:
*Create a locator(Create->Locator)
*Rename it to locPar_tongueCenterA
*Select the locator
*Select  the  tongueCenterA joint(either  with  shift  selection  from the  viewport  or  by Ctrl 
Selection through the Outliner)
*Use matchTransformsTool
*Parent the locator under the tongueCenterControl

Tongue Center Front A joint:
*Create a locator(Create->Locator)
*Rename it to locPar_tongueCenterFrontA
*Select the locator
*Select the tongueCenterFrontA joint(either with shift selection from the viewport or by Ctrl 
Selection through the Outliner)
*Use matchTransformsTool
*Parent the locator under the tongueCenterFrontControl

Left Lip Corner joint:
*Create a locator(Create->Locator)
*Rename it to locPoi_l_lip_corner
*Select the locator
*Select  the  l_lip_corner  joint(either  with  shift  selection  from  the  viewport  or  by  Ctrl 
Selection through the Outliner)
*Use matchTransformsTool
*Parent the locator under the l_lipCornerControl



Right Lip Corner joint:
*Create a locator(Create->Locator)
*Rename it to locPoi_r_lip_corner
*Select the locator
*Select  the  r_lip_corner  joint(either  with  shift  selection  from  the  viewport  or  by  Ctrl 
Selection through the Outliner)
*Use matchTransformsTool
*Parent the locator under the r_lipCornerControl

Left Upper Lip joint:
*Create a locator(Create->Locator)
*Rename it to locPoi_l_upperlip
*Select the locator
*Select the l_upperlip joint(either with shift selection from the viewport or by Ctrl Selection 
through the Outliner)
*Use matchTransformsTool
*Parent the locator under the l_upperLipControl

Center Upper Lip joint:
*Create a locator(Create->Locator)
*Rename it to locPoi_c_upperlip
*Select the locator
*Select the c_upperlip joint(either with shift selection from the viewport or by Ctrl Selection 
through the Outliner)
*Use matchTransformsTool
*Parent the locator under the c_upperLipControl

Right Upper Lip joint:
*Create a locator(Create->Locator)
*Rename it to locPoi_r_upperlip
*Select the locator
*Select the r_upperlip joint(either with shift selection from the viewport or by Ctrl Selection 
through the Outliner)
*Use matchTransformsTool
*Parent the locator under the r_upperLipControl

Left Lower Lip joint:
*Create a locator(Create->Locator)
*Rename it to locPoi_l_lowerlip
*Select the locator
*Select the l_lowerlip joint(either with shift selection from the viewport or by Ctrl Selection 
through the Outliner)
*Use matchTransformsTool
*Parent the locator under the l_lowerLipControl

Center Lower Lip joint:
*Create a locator(Create->Locator)
*Rename it to locPoi_c_lowerlip
*Select the locator
*Select the c_lowerlip joint(either with shift selection from the viewport or by Ctrl Selection 



through the Outliner)
*Use matchTransformsTool
*Parent the locator under the c_lowerLipControl

Right Lower Lip joint:
*Create a locator(Create->Locator)
*Rename it to locPoi_r_lowerlip
*Select the locator
*Select the r_lowerlip joint(either with shift selection from the viewport or by Ctrl Selection 
through the Outliner)
*Use matchTransformsTool
*Parent the locator under the r_lowerLipControl

Left Nostril Base joint:
*Create a locator(Create->Locator)
*Rename it to locPar_l_nostril_base
*Select the locator
*Select  the  l_nostril_base  joint(either  with  shift  selection  from the  viewport  or  by  Ctrl 
Selection through the Outliner)
*Use matchTransformsTool
*Parent the locator under the l_nostrilControl

Right Nostril Base joint:
*Create a locator(Create->Locator)
*Rename it to locPar_r_nostril_base
*Select the locator
*Select  the  r_nostril_base  joint(either  with  shift  selection  from the  viewport  or  by  Ctrl 
Selection through the Outliner)
*Use matchTransformsTool
*Parent the locator under the r_nostrilControl

Nose Tip joint:
*Create a locator(Create->Locator)
*Rename it to locPar_nose_tip
*Select the locator
*Select the nose_tip joint(either with shift selection from the viewport or by Ctrl Selection 
through the Outliner)
*Use matchTransformsTool
*Parent the locator under the mainNoseControl

Left Eyebrow 01 joint:
*Create a locator(Create->Locator)
*Rename it to locPoi_l_eyebrow01
*Select the locator
*Select  the  l_eyebrow01  joint(either  with  shift  selection  from  the  viewport  or  by  Ctrl 
Selection through the Outliner)
*Use matchTransformsTool
*Parent the locator under the l_eyebrow01Control

Left Eyebrow 02 joint:
*Create a locator(Create->Locator)



*Rename it to locPoi_l_eyebrow02
*Select the locator
*Select  the  l_eyebrow02  joint(either  with  shift  selection  from  the  viewport  or  by  Ctrl 
Selection through the Outliner)
*Use matchTransformsTool
*Parent the locator under the l_eyebrow02Control

Left Eyebrow 03 joint:
*Create a locator(Create->Locator)
*Rename it to locPoi_l_eyebrow03
*Select the locator
*Select  the  l_eyebrow03  joint(either  with  shift  selection  from  the  viewport  or  by  Ctrl 
Selection through the Outliner)
*Use matchTransformsTool
*Parent the locator under the l_eyebrow03Control

Left Eyebrow 04 joint:
*Create a locator(Create->Locator)
*Rename it to locPoi_l_eyebrow04
*Select the locator
*Select  the  l_eyebrow04  joint(either  with  shift  selection  from  the  viewport  or  by  Ctrl 
Selection through the Outliner)
*Use matchTransformsTool
*Parent the locator under the l_eyebrow04Control

Right Eyebrow 01 joint:
*Create a locator(Create->Locator)
*Rename it to locPoi_r_eyebrow01
*Select the locator
*Select  the  r_eyebrow01  joint(either  with  shift  selection  from  the  viewport  or  by  Ctrl 
Selection through the Outliner)
*Use matchTransformsTool
*Parent the locator under the r_eyebrow01Control

Right Eyebrow 02 joint:
*Create a locator(Create->Locator)
*Rename it to locPoi_r_eyebrow02
*Select the locator
*Select  the  r_eyebrow02  joint(either  with  shift  selection  from  the  viewport  or  by  Ctrl 
Selection through the Outliner)
*Use matchTransformsTool
*Parent the locator under the r_eyebrow02Control

Right Eyebrow 03 joint:
*Create a locator(Create->Locator)
*Rename it to locPoi_r_eyebrow03
*Select the locator
*Select  the  r_eyebrow03  joint(either  with  shift  selection  from  the  viewport  or  by  Ctrl 
Selection through the Outliner)
*Use matchTransformsTool
*Parent the locator under the r_eyebrow03Control



Right Eyebrow 04 joint:
*Create a locator(Create->Locator)
*Rename it to locPoi_r_eyebrow04
*Select the locator
*Select  the  r_eyebrow04  joint(either  with  shift  selection  from  the  viewport  or  by  Ctrl 
Selection through the Outliner)
*Use matchTransformsTool
*Parent the locator under the r_eyebrow04Control



Appendix G:Applying Constraints on Ryan

Let's create them.We will also provide some explanation for the reason behind their 
use.

Global Control:
We would  like  the  global  control  to  be  able  to  move,rotate  and  scale  the  whole 

model,be it the geometry,ikHandles,skeleton or anything for that matter.We want to have a 
control to control them all in terms of the model's entity in a larger scene.We want everything 
to be treated as one entity which falls under parent constraint.Since the parent constraint does 
not include the scale channels we will also use a scale constraint.

Applying these two types of constraints to every node though would be too much of a 
hussle,not to mention we took the time to organise the nodes in groups which have the ability 
to  impose transforms on it's  children without  taking away their  own ability to  transform 
individually and apart from the rest of the group's children.So we will apply the constraints 
on groups and we need only apply them to JointsGRP and ControlsGRP.We do not need to 
apply  them to  GeometryGRP because  after  the  geometry  parts  have  been  bound  to  the 
skeleton any scaling we impose on the skeleton will be applied to the geometry as well.

JointsGRP:
*Select globalControl
*Select JointsGRP(either shift selecting from the viewport or ctrl selecting from the
Outliner)
*Parent  Constraint  without  offset.Go to Constrain->Parent  [].Make sure Maintain  
Offset is unchecked.The rest leave as is,and press Add.
*Scale Constraint without offset.Go to Constrain->Scale[].Make sure Maintain Offset 
is unchecked.The rest leave as is,and press Add.

ControlsGRP:
*Select globalControl
*Select ControlsGRP(either shift selecting from the viewport or ctrl selecting from the
Outliner)
*Parent  Constraint  without  offset.Go to Constrain->Parent  [].Make sure Maintain  
Offset is unchecked.The rest leave as is,and press Add.
*Scale Constraint without offset.Go to Constrain->Scale[].Make sure Maintain Offset 
is unchecked.The rest leave as is,and press Add.

Legs:
Left Leg:
First we need to connect the ikHandle of the leg to the controls.That can be achieved
with a point constraint.We will also use the l_kneeControl to constraint the ikHandle's 
pole vector.It would be confusing to say that we want the l_kneeControl to control  
where the knee aims at because of the existence of the aim constraint.But here we are 
talking about the orientation of an ikHandle therefore it is a pole vector constraint  
instead of an aim constraint.
*Select the l_RLAnkle joint
*Select ikHandle_l_leg(either shift selecting from the viewport or ctrl selecting from 
the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  



Offset is unchecked.The rest leave as is,and press Add.
The reason we don't need an offset is because the l_RL joint has been snapped to the 
l_ankle joint of the skeleton which is the end-joint of the ikHandle.Moreover,we are 
applying a point constraint that only cares for the translation channels.So even if these 
two joints don't have the same orientation,it will work.
*Select l_kneeControl
*Again select ikHandle_l_leg(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Pole Vector Constraint.Go to Constrain->Pole Vector.No need to fiddle with  it's  
settings.

Left Foot:
In the case of the foot and toe we only need a point constraint from the RL joint to the 
respective ikHandle.One would wonder,how do we simulate the heel being lifted up 
while the foot stays  on the ground.If you think about it  it  can be rephrased as a  
rotation on the foot joint(the metatarsal joint since we are using the H-anim Standard).
But we can't rotate the end effector of an ikHandle and see the ikHandle itself get  
rotated around it's end effector.The Reverse Foot Lock is a design that takes care of
this problem.The key of this whole system is on the word Reverse,meaning a reverse 
hierarchy than that of the skeleton sub chain from the ankle to the toes.When we  
rotate the l_RLFoot joint,based on the hierarchy the l_RLAnkle is moved to a higher 
place.At the same time it  drags  with it  the ikHandle of  the leg,thus  creating the  
illusion that rotating the l_RLFoot joint rotates the single chain ikHandle of the foot 
on it's end effector.
*Select the l_RLFoot joint
*Select ikHandle_SC_l_foot(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

Left Toes:
The same principles(see Left Foot) apply to the toes too.
*Select the l_RLToe joint
*Select ikHandle_SC_l_toe(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

Right Leg:
*Select the r_RLAnkle joint
*Select ikHandle_r_leg(either shift selecting from the viewport or ctrl selecting from 
the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select r_kneeControl
*Again select ikHandle_r_leg(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Pole Vector  Constraint.Go to Constrain->Pole Vector.No need to  fiddle with it's  
settings.



Right Foot:
*Select the r_RLFoot joint
*Select ikHandle_SC_r_foot(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

Right Toes:
*Select the r_RLToe joint
*Select ikHandle_SC_r_toe(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

Torso & Hips:
From this point forward,bear in mind that all constraints with a locator as a driver will  

effectively mean that the respective control is the real driver since the locators are parented 
under the controls.Since those locators were created to match the joint's transforms we will 
apply all matter of constraints without offsets(Maintain Offset unchecked).

Hips:
We have chosen to  parent  constraint  the HumanoidRoot  joint  to  the hip controls  
because apart from the obvious reason of the translation ,the human body can rotate 
slightly in the hip area.
*Select locPar_HumanoidRoot
*Select the HumanoidRoot joint
*Parent  Constraint  without  offset.Go to  Constrain->Parent  [].Make sure Maintain  
Offset is unchecked.The rest leave as is,and press Add.

It's high time we used those clusters we created during the ikSpline for the spine. 
Moving them around,bends the curve the ikSpline works with.We will point constraint the 
clusters to the appropriate controls because observing the human body you will see that no 
rotations take place in those points.The only rotation is the one taking place at the end of the 
ikSpline.

Abs:
*Select absControl
*Select the cl_abs cluster(either shift selecting from the viewport or ctrl selecting  
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

Chest:
*Select chestControl
*Select the cl_chest cluster(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

Back:
*Select backControl



*Select the cl_neck cluster(either shift selecting from the viewport or ctrl selecting  
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

For the clavicles we would like to move them and rotate them somehow but since we 
have only one control we cannot use pole vector constraint.There is a way though,we can use 
connections which we will explain in Section 2.2.8.

Left Clavicle:
*Select l_shoulderControl
*Select ikHandle_l_shoulder(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

Right Clavicle:
*Select r_shoulderControl
*Select  the  ikHandle_r_shoulder(either  shift  selecting  from  the  viewport  or  ctrl  
selecting from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

Arms:
The arms are pretty much the same with the legs.We want to use the l_wristControl to 

control the wrist movement and the whole arm since it is an ikHandle just like the l_RLAnkle 
joint  did for  the leg ikHandle.Also just  like we used a  pole vector  constrained from the 
kneeControl  to  the  leg  ikHandle,we  will  do  the  same  for  the  elbowControl  to  the  arm 
ikHandle.

Left Arm:
*Select l_wristControl
*Select  ikHandle_l_wrist(either  shift  selecting from the viewport  or ctrl  selecting  
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select l_elbowControl
*Again  select  ikHandle_l_wrist(either  shift  selecting  from  the  viewport  or  ctrl  
selecting from the Outliner)
*Pole Vector  Constraint.Go to Constrain->Pole Vector.No need to  fiddle with it's  
settings.

Left Hand:
*Select locOri_l_wrist
*Select the l_wrist joint(either shift selecting from the viewport or ctrl selecting from  
the Outliner)
*Orient  Constraint  without  offset.Go to Constrain->Orient  [].Make sure Maintain  
Offset is unchecked.The rest leave as is,and press Add.

Right Arm:
*Select r_wristControl



*Select  ikHandle_r_wrist(either  shift  selecting from the viewport or ctrl  selecting  
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select r_elbowControl
*Again  select  ikHandle_r_wrist(either  shift  selecting  from  the  viewport  or  ctrl  
selecting from the Outliner)
*Pole Vector  Constraint.Go to Constrain->Pole Vector.No need to  fiddle with it's  
settings.

Right Hand:
*Select locOri_r_wrist
*Select the r_wrist joint(either shift selecting from the viewport or ctrl selecting from  
the Outliner)
*Orient  Constraint  without  offset.Go to Constrain->Orient  [].Make sure Maintain  
Offset is unchecked.The rest leave as is,and press Add.

Neck & Head:

Neck:
The human head moves and rotates by the neck.Therefore we will  constraint the  
translation of the ikHandle which will determine the position of the head and also  
constraint the rotation of the vc1 joint(the end effector of the ikHandle) to simulate the 
orientation of the head.
*Select neckControl
*Select ikHandle_neck(either shift selecting from the viewport or ctrl selecting from 
the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locOri_vc1
*Select the vc1 joint(either shift selecting from the viewport or ctrl selecting from the 
Outliner)
*Orient  Constraint  without  offset.Go to Constrain->Orient  [].Make sure Maintain  
Offset is unchecked.The rest leave as is,and press Add.

Skull Base:
We've already mentioned it that the at the skullbase only rotation makes sense.We  
might already have the neck for rotating the head but we can use this as a second  
degree of rotation.
*Select locOri_skullbase
*Select the skullbase joint(either shift selecting from the viewport or ctrl selecting  
from the Outliner)
*Orient  Constraint  without  offset.Go to Constrain->Orient  [].Make sure Maintain  
Offset is unchecked.The rest leave as is,and press Add.

Jaw:
Naturally the jaw rotates on the X axis.Therefore we will orient constraint.
*Select locOri_lowerJaw_Pivot



*Select lowerJaw_Pivot(either shift selecting from the viewport or ctrl selecting from 
the Outliner)
*Orient  Constraint  without  offset.Go to  Constrain->Orient  [].Make sure Maintain  
Offset is unchecked.The rest leave as is,and press Add.

Tongue:
We have four pivots of rotation(yes the tongue can only rotate ,or bend if you like,but 
it cannot translate,moreso when we have four transformable points) in the tongue for 
great control and an opportunity to simulate fluid motions seeing as there are no bones 
in the tongue in reality.
*Select locPar_tongueBaseA
*Select the tongueBaseA(either shift  selecting from the viewport or ctrl  selecting  
from the Outliner)
*Parent  Constraint  without  offset.Go to  Constrain->Parent  [].Make sure Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPar_tongueCenterBackA
*Select  the  tongueCenterBackA(either  shift  selecting  from  the  viewport  or  ctrl  
selecting from the Outliner)
*Parent  Constraint  without  offset.Go to  Constrain->Parent  [].Make sure Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPar_tongueCenterA
*Select the tongueCenterA(either shift selecting from the viewport or ctrl selecting  
from the Outliner)
*Parent  Constraint  without  offset.Go to  Constrain->Parent  [].Make sure Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPar_tongueCenterFrontA
*Select  the  tongueCenterFrontA(either  shift  selecting  from  the  viewport  or  ctrl  
selecting from the Outliner)
*Parent  Constraint  without  offset.Go to  Constrain->Parent  [].Make sure Maintain  
Offset is unchecked.The rest leave as is,and press Add.

Lips:
We defined 8 points on the lips we can transform.We only need translations so just  
point constraint every locator to the appropriate joint.
*Select locPoi_l_upperlip
*Select the l_upperlip joint(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPoi_c_upperlip
*Select the c_upperlip joint(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPoi_r_upperlip



*Select the r_upperlip joint(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPoi_l_lowerlip
*Select the l_lowerlip joint(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPoi_c_lowerlip
*Select the c_lowerlip joint(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPoi_r_lowerlip
*Select the r_lowerlip joint(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPoi_l_lip_corner
*Select the l_lip_corner joint(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPoi_r_lip_corner
*Select the r_lip_corner joint(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

Nose:
Normally in the nose area only the nostrils would be transformable but a broken nose 
is easy to reproduce with a parent constraint on the nose tip.
*Select locPar_nose_tip
*Select the nose_tip joint(either shift selecting from the viewport or ctrl selecting  
from the Outliner)
*Parent  Constraint  without  offset.Go to Constrain->Parent  [].Make sure Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPar_l_nostril_base
*Select  the  l_nostril_base  joint(either  shift  selecting  from  the  viewport  or  ctrl  
selecting from the Outliner)
*Parent  Constraint  without  offset.Go to Constrain->Parent  [].Make sure Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPar_r_nostril_base



*Select  the  r_nostril_base  joint(either  shift  selecting  from  the  viewport  or  ctrl  
selecting from the Outliner)
*Parent  Constraint  without  offset.Go to Constrain->Parent  [].Make sure Maintain  
Offset is unchecked.The rest leave as is,and press Add.

Eyes:
We will point constraint the eye controls to the eye ikHandles.Translating the controls 
will point the eyes towards that position.If you think about it,that's about everything 
the eyes themselves can do.
*Select l_eyeControl
*Select ikHandle_l_eyeball(either shift selecting from the viewport or ctrl selecting  
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select r_eyeControl
*Select ikHandle_r_eyeball(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

Brows:
We defined 4 points on each brow we can transform.We only need translations so just 
point constraint every locator to the appropriate joint.
*Select locPoi_l_eyebrow01
*Select the l_eyebrow01 joint(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPoi_l_eyebrow02
*Select the l_eyebrow02 joint(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPoi_l_eyebrow03
*Select the l_eyebrow03 joint(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPoi_l_eyebrow04
*Select the l_eyebrow04 joint(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPoi_r_eyebrow01
*Select the r_eyebrow01 joint(either shift selecting from the viewport or ctrl selecting 
from the Outliner)



*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPoi_r_eyebrow02
*Select the r_eyebrow02 joint(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPoi_r_eyebrow03
*Select the r_eyebrow03 joint(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

*Select locPoi_r_eyebrow04
*Select the r_eyebrow04 joint(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.

"Sticky" Facial Controls:
At this  point  we have  the  controls  working,influencing joints  and some of  them  
parented to others,like the lip controls to the lower jaw control because wherever the 
jaw  goes  the  lips  must  follow  even  if  they  have  their  own  independent  
transformations.Alas  we have  to  make sure they move with the  overall  head.For  
example,when rotating with the neckControl we must make sure every facial control 
follows. We can do just that if we find something that is static in the sense that it does 
not transform by it's own or by any control.Here I used the temporomandibular joint 
that is always at the center(approximately) of the head.In order for the facial controls 
to move along with the temporomandibular joint we need to make them one sole  
entity.That can be achieved with the use of parent constraints where the driver ,or  
parent if it makes it easier to understand, is the temporomandibular joint.In contrast to 
pretty much every other constraint we've made,we have to make sure this time we use 
the Maintain Offset option.
Every  control's  pivot  is  at  a  different  position  and  none  of  them  rests  on  the  
temporomandibular joint.Hence the Maintain Offset option,the constraints make sure 
to transform every control as much as it needs to preserve it's place on the Head.
*Select the temporomandibular joint
*Select lowerJawControlGRP(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Parent  Constraint  with  offset.Go  to  Constrain->Parent  [].Make  sure  Maintain  
Offset is checked.The rest leave as is,and press Add.

*Select the temporomandibular joint
*Select upperLip_controlGRP(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Parent  Constraint  with  offset.Go  to  Constrain->Parent  [].Make  sure  Maintain  
Offset is checked.The rest leave as is,and press Add.

*Select the temporomandibular joint



*Select noseControlsGRP(either shift selecting from the viewport or ctrl selecting  
from the Outliner)
*Parent  Constraint  with  offset.Go  to  Constrain->Parent  [].Make  sure  Maintain  
Offset is checked.The rest leave as is,and press Add.

*Select the temporomandibular joint
*Select l_brow_controlGRP(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Parent  Constraint  with  offset.Go  to  Constrain->Parent  [].Make  sure  Maintain  
Offset is checked.The rest leave as is,and press Add.

*Select the temporomandibular joint
*Select r_brow_controlGRP(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Parent  Constraint  with  offset.Go  to  Constrain->Parent  [].Make  sure  Maintain  
Offset is checked.The rest leave as is,and press Add.

There  are  also  those  controls  that  do  not  need  to  be  connected  to  the  
temporomandibular joint because they have to be connected with other controls.
The lowerLip_controlGRP specifically  just  needs  to  be  parent  constrained to  the  
lowerJawControl which is in turn parent constrained to the temporomandibular joint.
*Select lowerJawControl
*Select lowerLip_controlGRP(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Parent  Constraint  with  offset.Go  to  Constrain->Parent  [].Make  sure  Maintain  
Offset is checked.The rest leave as is,and press Add.

To accomplish a second level of rotation to the head,the control for that second level 
must be connected with the control for the first level.In short the headRotationControl 
rotating around the skullbase must first follow the rotation of the neck.
*Select neckControl
*Select  headRotationControlGRP(either  shift  selecting  from  the  viewport  or  ctrl  
selecting from the Outliner)
*Parent  Constraint  with  offset.Go  to  Constrain->Parent  [].Make  sure  Maintain  
Offset is checked.The rest leave as is,and press Add.

"Special" Controls:
Apart from a point constraint that will help in the creation of one aim constraint we 
are going to use for the eye controls ,the meaning of the rest will be revealed in the 
next section.

We will implement a trick where moving the eye controls around will also rotate the 
individual eye controls at their pivot in order to show where the eyes point.

*Select the head_back_Pivot joint
*Select  headBackMarker(either  shift  selecting from the viewport  or  ctrl  selecting  
from the Outliner)
*Point  Constraint  without  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is unchecked.The rest leave as is,and press Add.



We created an object on the back of the head that will follow the back of the head 
wherever.We will use it as a point of reference for the eye controls to point towards.
*Select headBackMarker
*Select eyesAimGRP(either shift selecting from the viewport or ctrl selecting from 
the Outliner)

*Aim Constraint with offset.Go to Constrain->Aim[].First go to Edit->Reset Settings.
It is very important because the slightest mistake will get you an incomprehensible  
behaviour.Make sure Maintain Offset is checked.The World Up type must be set to 
Object Up,which means we are going to use an object as a point of reference,where all 
aim vectors are going to originate from.The Aim vector resides on the X axis and the 
Up vector on the Y axis(as set in the fields).We know that a vector can be seen as a 
point (x-x0,y-y0,z-z0) where the origin is the point (x0,y0,z0).That means that the x 
coordinate will be along the X axis,the y coordinate on the Y axis and the z coordinate 
will be the constrained object's z coordinate.The origin(x0,y0,z0) here will be the  
reference  object's  pivot  point,basically  headBackMarker's  pivot.So  we  enter  
headBackMarker in the World up object field.The rest you can leave as they are and 
press Add.

Move the mainEyeControl around and you'll see the trick in action.

In order to finish with the constraints we have some more to create in preparation for 
the next section.

*Select headRotationControl
*Select  eyeControlsGRP(either  shift  selecting  from the  viewport  or  ctrl  selecting  
from the Outliner)
*Parent  Constraint  with  offset.Go  to  Constrain->Parent  [].Make  sure  Maintain  
Offset is checked.The rest leave as is,and press Add.

*Select l_RLBase
*Select l_kneeControlGRP(either shift selecting from the viewport or ctrl selecting  
from the Outliner)
*Point  Constraint  with  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is checked.The rest leave as is,and press Add.

*Select r_RLBase
*Select r_kneeControlGRP(either shift selecting from the viewport or ctrl selecting  
from the Outliner)
*Point  Constraint  with  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is checked.The rest leave as is,and press Add.

*Select l_wristControl
*Select l_elbowControlGRP(either shift selecting from the viewport or ctrl selecting 
from the Outliner)
*Point  Constraint  with  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is checked.The rest leave as is,and press Add.

*Select r_wristControl
*Select r_elbowControlGRP(either shift selecting from the viewport or ctrl selecting 
from the Outliner)



*Point  Constraint  with  offset.Go  to  Constrain->Point  [].Make  sure  Maintain  
Offset is checked.The rest leave as is,and press Add.



Appendix H:Extra features for Ryan

Legs:
Feet:
To create the Foot Roll we will first create the attribute in left foot controls.
*Select l_footControl
*In channel box,Edit->Add Attribute
*Enter Foot Roll in Long Name
*Select Keyable in Make attribute
*Select Float as Data Type
*Enter -10 in Minimum,10 in Maximum and 0 in Default.
*Click Ok
Now that the attribute is in place,we will create the driven keys.
*Animate->Set Driven Key->Set...
*Select l_footControl
*Click on Load Driver in the Set Driven Key window
*Select l_RLBase and shift select l_RLToe,l_RLFoot,l_RLAnkle
*Click on Load Driven in the Set Driven Key window
*On the Set Driven Key window,select l_footControl and then select FootRoll on the 
right side
*Again on the Set Driven Key window,select all RL joints on the left side and rotateZ 
on the right side.
*Click on Key
*Select l_footControl and set Foot Roll to -10
*Select l_RLBase and set rotateZ to -28
*On the Set Driven Key window,select l_footControl and then select FootRoll on the 
right side
*Again on the Set Driven Key window,select l_RLBase on the left side and rotateZ on 
the right side.
*Click on Key
*Select l_footControl and set Foot Roll to  10
*Select l_RLFoot and set rotateZ to -8
*Select l_RLToe and set rotateZ to -65
*On the Set Driven Key window,select l_footControl and then select FootRoll on the 
right side
*Again on the Set Driven Key window,select l_RLToe and l_RLFoot on the left side 
 and rotateZ on the right side.
*Click on Key
*Select l_footControl and set Foot Roll to  5
*Select l_RLFoot and set rotateZ to -27
*Select l_RLToe and set rotateZ to 0
*On the Set Driven Key window,select l_footControl and then select FootRoll on the 
right side
*Again on the Set Driven Key window,select l_RLToe and l_RLFoot on the left side 
 and rotateZ on the right side.
*Click on Key
*Select l_footControl and set Foot Roll to  6
*Select l_RLFoot and set rotateZ to -30
*On the Set Driven Key window,select l_footControl and then select FootRoll on the 



right side
*Again on the Set Driven Key window,select l_RLFoot on the left side and rotateZ on 
the right side.
*Click on Key
*Repeat all the above for r_footControl
*Set Foot Roll to 0 for both foot controls.

Knees:
To create the Knee Lock we will first create the attribute in left knee controls.
*Select l_kneeControl
*In channel box,Edit->Add Attribute
*Enter Knee Lock in Long Name
*Select Keyable in Make attribute
*Select Boolean as Data Type
*Click Ok
Now that the attribute is in place,we will create the driven keys.
*Animate->Set Driven Key->Set...
*Select l_kneeControl
*Click on Load Driver in the Set Driven Key window
*Select the point constraint under l_kneeControlGRP
 (l_kneeControlGRP_pointConstraint1)
*Click on Load Driven in the Set Driven Key window
*Select the point constraint under l_kneeControlGRP
 (l_kneeControlGRP_pointConstraint1) and set l_RLBaseW0 to 0
*On the Set Driven Key window,select l_footControl and then select KneeLock on the 
right side
*Again on the Set Driven Key window,select the point constraint on the left side and 
l_RLBaseW0 on the right side.
*Click on Key
*Select l_kneeControl and set Knee Lock to 1
*Select the point constraint under l_kneeControlGRP
 (l_kneeControlGRP_pointConstraint1) and set l_RLBaseW0 to 1
*On the Set Driven Key window,select l_footControl and then select KneeLock on the 
right side
*Again on the Set Driven Key window,select the point constraint on the left side and 
l_RLBaseW0 on the right side.
*Click on Key
*Repeat all the above for r_footControl
*Set Knee Lock to 1 for both knee controls.

Torso & Hips:
Chest:
*Select chestControl
*In the channel box,Edit->Connection Editor
*Select ikHandle_Spline_spine
*On the Connection Editor window,click on Reload Right.
*On the Connection Editor window,click on rotateY on the left side and then click on 
twist on the right side.
*Click on Close

Clavicles:



*Select l_shoulderControl
*In channel box,Edit->Add Attribute
*Enter Clav Twist in Long Name
*Select Keyable in Make attribute
*Select Float as Data Type
*Enter 0 in Default.
*Click Ok
*In the channel box,Edit->Connection Editor
*Select ikHandle_l_clavicle
*On the Connection Editor window,click on Reload Right.
*On the Connection Editor window,click on ClavTwist on the left side and then click 
on twist on the right side.
*Click on Close
*Repeat all the above for r_shoulderControl

Arms:
The arms are pretty much the same with the legs.We want to use the l_wristControl to 

control the wrist movement and the whole arm since it is an ikHandle just like the l_RLAnkle 
joint  did for the leg ikHandle.Also just  like we used a  pole vector  constrained from the 
kneeControl  to  the  leg  ikHandle,we  will  do  the  same  for  the  elbowControl  to  the  arm 
ikHandle.

Elbows:
To create the Elbow Lock we will first create the attribute in the left elbow control.
*Select l_elbowControl
*In channel box,Edit->Add Attribute
*Enter Elbow Lock in Long Name
*Select Keyable in Make attribute
*Select Boolean as Data Type
*Click Ok
Now that the attribute is in place,we will create the driven keys.
*Animate->Set Driven Key->Set...
*Select l_elbowControl
*Click on Load Driver in the Set Driven Key window
*Select the point constraint under l_elbowControlGRP
 (l_elbowControlGRP_pointConstraint1)
*Click on Load Driven in the Set Driven Key window
*Select the point constraint under l_elbowControlGRP
 (l_elbowControlGRP_pointConstraint1) and set l_wristControlW0 to 0
*On the Set Driven Key window,select l_elbowControl and then select ElbowLock on 
the right side
*Again on the Set Driven Key window,select the point constraint on the left side and 
l_wristControlW0 on the right side.
*Click on Key
*Select l_elbowControl and set Elbow Lock to 1
*Select the point constraint under l_elbowControlGRP
 (l_elbowControlGRP_pointConstraint1) and set l_wristControlW0 to 1
*On the Set Driven Key window,select l_wristControl and then select ElbowLock on 
the right side
*Again on the Set Driven Key window,select the point constraint on the left side and 
l_wristControlW0 on the right side.



*Click on Key
*Repeat all the above for r_elbowControl
*Set Elbow Lock to 1 for both elbow controls.

Wrists:
To create the Fist we will first create the attribute in left wrist controls.
*Select l_wristControl
*In channel box,Edit->Add Attribute
*Enter Fist in Long Name
*Select Keyable in Make attribute
*Select Boolean as Data Type
*Click Ok
Now that the attribute is in place,we will create the driven keys.
*Animate->Set Driven Key->Set...
*Select l_wristControl
*Click on Load Driver in the Set Driven Key window
*Select all finger joints(pinky,ring,middle,index and thumb joints)
*Click on Load Driven in the Set Driven Key window
*On the Set Driven Key window,select l_wristControl and then select Fist on the  
right side
*Again  on  the  Set  Driven  Key  window,select  all  fingers  on  the  left  side  and  
rotateZ on the right side.
*Click on Key
*Select l_wristControl and set Fist to 1
*Select the pinky,ring,middle and index joints and set their rotateZ to 72.894
*Select all three thumb joints and set rotate Z to 77.449
*On the Set Driven Key window,select l_wristControl and then select Fist on the  
right side
*Again on the Set Driven Key window,select all finger joints in the left side and  
rotateZ on the right side
*Click on Key
*Repeat all the above for r_wristControl
*Set Fist to 0 for both wrist controls.

Neck & Head:
Tongue:
To  create  the  Bend  we  will  first  create  the  attribute  in  the  first  tongue  
control(tongueBaseControl)
*Select tongueBaseControl
*In channel box,Edit->Add Attribute
*Enter Bend in Long Name
*Select Keyable in Make attribute
*Select Float as Data Type
*Enter 0 as the default Value
*Click Ok
*In channel box,Edit->Connection Editor
*Select l_tongueBaseB, r_tongueBaseB
*On the Connection Editor window click on Reload Right
*Select Bend on the left side
*Select rotateZ on both l_tongueBaseB and r_tongueBaseB on the right side.



*Repeat all the above for tongueCenterBackControl,tongueCenterControl
and tongueCenterFrontControl,merely swapping Base for either CenterBack,Center  
and CenterFront

Nose:
To create the Flare attributes we will first create them in the main nose control
*Select mainNoseControl
*In channel box,Edit->Add Attribute
*Enter FlareX in Long Name
*Select Keyable in Make attribute
*Select Float as Data Type
*Enter 1 in Default.
*Click Add
*In channel box,Edit->Add Attribute
*Enter FlareY in Long Name
*Select Keyable in Make attribute
*Select Float as Data Type
*Enter 1 in Default.
*Click Add
*In channel box,Edit->Add Attribute
*Enter FlareZ in Long Name
*Select Keyable in Make attribute
*Select Float as Data Type
*Enter 1 in Default.
*Click Ok
*In channel box,Edit->Connection Editor
*Select the nose_tip joint
*On the Connection Editor window,click on Reload Right
*Select FlareX on the left side and scaleX on the right side
*Select FlareY on the left side and scaleY on the right side
*Select FlareZ on the left side and scaleZ on the right side
*Repeat  all  the  above  for  the  l_nostrilControl  and r_nostrilControl,swapping  the  
nose_tip joint for either the l_nostril_base joint or the r_nostril_base_joint.

Eyes:
We will create Blinks and sliders for the lids(upper and lower).
*Select mainEyeControl
*In channel box,Edit->Add Attribute
*Enter Parented_To_HeadRotation in Long Name
*Select Keyable in Make attribute
*Select Boolean as Data Type
*Click Add
*Enter EyeTargetMarkers in Long Name
*Select Keyable in Make attribute
*Select Boolean as Data Type
*Click Add
*Enter LeftEyeBlink in Long Name
*Select Keyable in Make attribute
*Select Boolean as Data Type
*Click Add
*Enter RightEyeBlink in Long Name



*Select Keyable in Make attribute
*Select Boolean as Data Type
*Click Add
*Enter LeftUpperLid in Long Name
*Select Keyable in Make attribute
*Select Float as Data Type
*Enter 0 in Default.
*Click Add
*Enter LeftLowerLid in Long Name
*Select Keyable in Make attribute
*Select Float as Data Type
*Enter 0 in Default.
*Click Add
*Enter RightUpperLid in Long Name
*Select Keyable in Make attribute
*Select Float as Data Type
*Enter 0 in Default.
*Click Add
*Enter RightLowerLid in Long Name
*Select Keyable in Make attribute
*Select Float as Data Type
*Enter 0 in Default.
*Click Ok
*In channel box,Edit->Connection Editor
*Select the l_upper_eyelid_base joint
*On the Connection Editor window click on Reload Right
*Select LeftUpperLid on the left side
*Select rotateZ on the right side.
*Select the l_lower_eyelid_base joint
*On the Connection Editor window click on Reload Right
*Select LeftLowerLid on the left side
*Select rotateZ on the right side.
*Select the r_lower_eyelid_base joint
*On the Connection Editor window click on Reload Right
*Select RightUpperLid on the left side
*Select rotateZ on the right side.
*Select the r_lower_eyelid_base joint
*On the Connection Editor window click on Reload Right
*Select RightLowerLid on the left side
*Select rotateZ on the right side.
*Click on Close
Now that the attributes is in place,we will create the driven keys.
*Animate->Set Driven Key->Set...
*Select mainEyeControl
*Click on Load Driver in the Set Driven Key window
*Select the parent constraint under eyeControlsGRP
(eyeControlsGRP_parentConstraint1)
*Click on Load Driven in the Set Driven Key window
*Select the parent constraint under eyeControlsGRP
(eyeControlsGRP_parentConstraint1) and set headRotationControlW0 to 0
*On  the  Set  Driven  Key  window,select  mainEyeControl  and  then  select  



Parented_To_HeadRotation on the right side
*Again on the Set Driven Key window,select the eyeControlsGRP_parentConstraint1 
on the left side and headRotationControlW0 on the right side.
*Click on Key
*Select mainEyeControl and set Parented_To_HeadRotation to 1
*Select the parent constraint under eyeControlsGRP
(eyeControlsGRP_parentConstraint1)
*Click on Load Driven in the Set Driven Key window
*Select the parent constraint under eyeControlsGRP
(eyeControlsGRP_parentConstraint1) and set headRotationControlW0 to 1
*On  the  Set  Driven  Key  window,select  mainEyeControl  and  then  select  
Parented_To_HeadRotation on the right side
*Again on the Set Driven Key window,select the eyeControlsGRP_parentConstraint1 
on the left side and headRotationControlW0 on the right side.
*Click on Key
*Select the point constraint under ikHandle_l_eyeball
(ikHandle_l_eyeball_pointConstraint1) and the point constraint under 
ikHandle_r_eyeball(ikHandle_r_eyeball_pointConstraint1)
*Click on Load Driven in the Set Driven Key window
*Select the point constraint under ikHandle_l_eyeball
(ikHandle_l_eyeball_pointConstraint1) and set the visibility to 0
*Select the point constraint under ikHandle_r_eyeball
(ikHandle_r_eyeball_pointConstraint1) and set the visibility to 0
*On  the  Set  Driven  Key  window,select  mainEyeControl  and  then  select  
EyeTargetMarkers on the right side
*Again on the Set Driven Key window,select both point constraints on the left side 
and visibility on the right side.
*Click on Key
*Select mainEyeControl and set EyeTargetMarkers to 1
*Select the point constraint under ikHandle_l_eyeball
(ikHandle_l_eyeball_pointConstraint1) and set the visibility to 1
*Select the point constraint under ikHandle_r_eyeball
(ikHandle_r_eyeball_pointConstraint1) and set the visibility to 1
*On  the  Set  Driven  Key  window,select  mainEyeControl  and  then  select  
EyeTargetMarkers on the right side
*Again on the Set Driven Key window,select both point constraints on the left side 
and visibility on the right side.
*Click on Key
*Select mainEyeControl
*Click on Load Driven in the Set Driven Key window
*Set LeftEyeBlink to 0,LeftUpperLid to 0 and LeftLowerLid to 0
*On  the  Set  Driven  Key  window,select  mainEyeControl  and  then  select  
LeftEyeBlink on the right side
*Again  on  the  Set  Driven  Key  window,select  mainEyeControl  on  the  left  side  
LeftUpperLid and LeftLowerLid on the right side.
*Click on Key
*Set LeftEyeBlink to 1,LeftUpperLid to 12 and LeftLowerLid to 12
*On  the  Set  Driven  Key  window,select  mainEyeControl  and  then  select  
LeftEyeBlink on the right side
*Again  on  the  Set  Driven  Key  window,select  mainEyeControl  on  the  left  side  
LeftUpperLid and LeftLowerLid on the right side.



*Click on Key
*Select mainEyeControl
*Click on Load Driven in the Set Driven Key window
*Set RightEyeBlink to 0,RightUpperLid to 0 and RightLowerLid to 0
*On  the  Set  Driven  Key  window,select  mainEyeControl  and  then  select  
RightEyeBlink on the right side
*Again  on  the  Set  Driven  Key  window,select  mainEyeControl  on  the  left  side  
RightUpperLid and RightLowerLid on the right side.
*Click on Key
*Set RightEyeBlink to 1,RightUpperLid to 12 and RightLowerLid to 12
*On  the  Set  Driven  Key  window,select  mainEyeControl  and  then  select  
RightEyeBlink on the right side
*Again  on  the  Set  Driven  Key  window,select  mainEyeControl  on  the  left  side  
RightUpperLid and RightLowerLid on the right side.
*Click on Key
*Set all custom attributes to 0 apart from Parented_To_HeadRotation which is to be 1

"Special" Controls:
To create the ShowHeadBackMarker.
*Select headRotationControl
*In channel box,Edit->Add Attribute
*Enter ShowHeadBackMarker in Long Name
*Select Keyable in Make attribute
*Select Boolean as Data Type
*Click Ok
Now that the attribute is in place,we will create the driven keys.
*Animate->Set Driven Key->Set...
*Select headRotationControl
*Click on Load Driver in the Set Driven Key window
*Select headBackMarker
*Click on Load Driven in the Set Driven Key window
*Select the headBackMarker and set visibility to 0
*On  the  Set  Driven  Key  window,select  headRotationControl  and  then  select  
ShowHeadBackMarker on the right side
*Again on the Set Driven Key window,select the headBackMarker on the left side and 
visibility on the right side.
*Click on Key
*Select headRotationControl and set ShowHeadBackMarker to 1
*Select headBackMarker  and set visibility to 1
*On  the  Set  Driven  Key  window,select  headRotationControl  and  then  select  
ShowHeadBackMarker on the right side
*Again on the Set Driven Key window,select the headBackMarker on the left side and 
visibility on the right side.
*Click on Key



Appendix I:Creating Blendshapes

Blendshapes have two stages.If we were to create blendshapes for the face,the first 
stage would be to create duplicates of the face mesh and modify them into different 
expressions.One great and quick way,for our case,is to use the joint based facial animation 
version of Ryan and use the facial controls to create an expression.When the expression is 
made,we just duplicate the face mesh,move the duplicate to the side and rename it according 
to the expression it has.When we have enough duplicates/expressions,select them all and 
export them in a different mayaAscii file.In the blendshape-based version of Ryan we are 
trying to create,import the blendshapes file(Uncheck the Use namespaces option and choose 
Clashing nodes in the Resolve dropbox option,this will import the blendshapes without 
namespaces as long as there is no common name).The second stage is to select all 
participants and create the blendshape nodes.Select all face mesh duplicates,lastly shift select 
the target face mesh(the one to be deformed) and go to Create Deformers->Blend 
Shape[].Leave the default settings and enter a name for the Blend Shape node.That's it,now 
you can delete the face mesh duplicates since the blendshape node is created and access the 
blendshape animation through Window->Animation Editors->Blend Shape.Find the control 
panel with the name you entered,if there are more than one, and play with the sliders to see 
the result.You can also click on Key,to key the value for the particular blendshape control.



Appendix J:Creating Feature Points and connecting them to the main 
body

Blendshapes are based on the notion that we have different and static states to blend 
between in order to create all expressions.Feature Points,on the other hand,are a control 
system that influences the original meshes.They are comprised of joints and controls. 
Normally the joints would be added as influence objects on the original meshes but since they 
take up influence from the other well defined joints,there was a need for a second layer of 
influence,where they could be influence objects,that would act on top of the original.Out 
from it came the idea to use blendshapes.Basically the system is a duplicate of all of the 
model's meshes with one root joint on which they are all bound to and all feature point joints 
added as influence objects.Then we create blendshape nodes for each geometry part,between 
the duplicate and the original, and when we use a control we influence the duplicate which in 
turn gets back to the original through the blendshape node.It's a dynamic blendshape 
system,where there are controls instead of multiple static duplicates to blend between. 

First,hide the original Ryan through the visibility layers.Import the skin again from 
Ryan_Skin.ma,but delete the eyes,the teeth and the tongue.Rename the imported meshes to 
FeaturePoints_(original  name  without  namespace),ie  FeaturePoints_Face.When  you  have 
selected which feature points you are going to create from the H-anim Standard,start creating 
joints and name them after the feature points(take care to name them from the H-anim and 
not the CEASAR naming pattern).We chose the following: selion, infraorbitale(l&r), tragion 
(l&r),nuchale,gonion(l&r),supramenton,neck  base(l&r),  cervicale,  acromion(l&r),  clavicale 
(l&r),suprasternale,biceps  brachii(l&r),  triceps  brachii(l&r),  axilla  ant(l&r),  thelion(l&r), 
substernale,rib10(l&r),navel,iliocristale(l&r),gluteus maximus(l&r),trochanterion(l&r),crotch, 
biceps femoris(l&r),rectus femoris(l&r),gastrocnemius(l&r).

After the joints are in place we will create the controls:
cervicaleControl:

*Create a joint curve control called cervicaleControl as instructed 
in Additional Instructions
*Shift select the cervicale joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

crotchControl:
*Create a joint curve control called crotchControl as instructed 
in Additional Instructions
*Shift select the crotch joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

l_gluteus_maximusControl:
*Create a joint curve control called l_gluteus_maximusControl as instructed 
in Additional Instructions
*Shift select the l_gluteus_maximus joint
*Use matchPositionTool
*Go into component mode and select all vertices



*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

r_gluteus_maximusControl:
*Create a joint curve control called r_gluteus_maximusControl as instructed 
in Additional Instructions
*Shift select the r_gluteus_maximus joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

l_gonionControl:
*Create a joint curve control called l_gonionControl as instructed 
in Additional Instructions
*Shift select the l_gonion joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

r_gonionControl:
*Create a joint curve control called r_gonionControl as instructed 
in Additional Instructions
*Shift select the r_gonion joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

l_iliocristaleControl:
*Create a joint curve control called l_iliocristaleControl as instructed 
in Additional Instructions
*Shift select the l_iliocristale joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

r_iliocristaleControl:
*Create a joint curve control called r_iliocristaleControl as instructed 
in Additional Instructions
*Shift select the r_iliocristale joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

l_infraorbitaleControl:
*Create a joint curve control called l_infraorbitaleControl as instructed 
in Additional Instructions



*Shift select the l_infraorbitale joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

r_infraorbitaleControl:
*Create a joint curve control called r_infraorbitaleControl as instructed 
in Additional Instructions
*Shift select the r_infraorbitale joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

l_acromionControl:
*Create a joint curve control called l_acromionControl as instructed 
in Additional Instructions
*Shift select the l_acromion joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

l_axilla_antControl:
*Create a joint curve control called l_axilla_antControl as instructed 
in Additional Instructions
*Shift select the l_axilla_ant joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

l_biceps_brachiiControl:
*Create a joint curve control called l_biceps_brachiiControl as instructed 
in Additional Instructions
*Shift select the l_biceps_brachii joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

l_triceps_brachiiControl:
*Create a joint curve control called l_triceps_brachiiControl as instructed 
in Additional Instructions
*Shift select the l_triceps_brachii joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations



l_clavicaleControl:
*Create a joint curve control called l_clavicaleControl as instructed 
in Additional Instructions
*Shift select the l_clavicale joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

l_biceps_femorisControl:
*Create a joint curve control called l_biceps_femorisControl as instructed 
in Additional Instructions
*Shift select the l_biceps_femoris joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

l_rectus_femorisControl:
*Create a joint curve control called l_rectus_femorisControl as instructed 
in Additional Instructions
*Shift select the l_rectus_femoris joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

l_gastrocnemiusControl:
*Create a joint curve control called l_gastrocnemiusControl as instructed 
in Additional Instructions
*Shift select the l_gastrocnemius joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

l_trochanterionControl:
*Create a joint curve control called l_trochanterionControl as instructed 
in Additional Instructions
*Shift select the l_trochanterion joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

navelControl:
*Create a joint curve control called navelControl as instructed 
in Additional Instructions
*Shift select the navel joint
*Use matchPositionTool
*Go into component mode and select all vertices



*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

l_neck_baseControl:
*Create a joint curve control called l_neck_baseControl as instructed 
in Additional Instructions
*Shift select the l_neck_base joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

r_neck_baseControl:
*Create a joint curve control called r_neck_baseControl as instructed 
in Additional Instructions
*Shift select the r_neck_base joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

nuchaleControl:
*Create a joint curve control called nuchaleControl as instructed 
in Additional Instructions
*Shift select the nuchale joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

r_acromionControl:
*Create a joint curve control called r_acromionControl as instructed 
in Additional Instructions
*Shift select the r_acromion joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

r_axilla_antControl:
*Create a joint curve control called r_axilla_antControl as instructed 
in Additional Instructions
*Shift select the r_axilla_ant joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

r_biceps_brachiiControl:
*Create a joint curve control called r_biceps_brachiiControl as instructed 
in Additional Instructions



*Shift select the r_biceps_brachii joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

r_triceps_brachiiControl:
*Create a joint curve control called r_triceps_brachiiControl as instructed 
in Additional Instructions
*Shift select the r_triceps_brachii joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

r_clavicaleControl:
*Create a joint curve control called r_clavicaleControl as instructed 
in Additional Instructions
*Shift select the r_clavicale joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

r_biceps_femorisControl:
*Create a joint curve control called r_biceps_femorisControl as instructed 
in Additional Instructions
*Shift select the r_biceps_femoris joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

r_rectus_femorisControl:
*Create a joint curve control called r_rectus_femorisControl as instructed 
in Additional Instructions
*Shift select the r_rectus_femoris joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

r_gastrocnemiusControl:
*Create a joint curve control called r_gastrocnemiusControl as instructed 
in Additional Instructions
*Shift select the r_gastrocnemius joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations



r_trochanterionControl:
*Create a joint curve control called r_trochanterionControl as instructed 
in Additional Instructions
*Shift select the r_trochanterion joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

l_rib10Control:
*Create a joint curve control called l_rib10Control as instructed 
in Additional Instructions
*Shift select the l_rib10 joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

r_rib10Control:
*Create a joint curve control called r_rib10Control as instructed 
in Additional Instructions
*Shift select the r_rib10 joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

sellionControl:
*Create a joint curve control called sellionControl as instructed 
in Additional Instructions
*Shift select the sellion joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

substernaleControl:
*Create a joint curve control called substernaleControl as instructed 
in Additional Instructions
*Shift select the substernale joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

supramentonControl:
*Create a joint curve control called supramentonControl as instructed 
in Additional Instructions
*Shift select the supramenton joint
*Use matchPositionTool
*Go into component mode and select all vertices



*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

suprasternaleControl:
*Create a joint curve control called suprasternaleControl as instructed 
in Additional Instructions
*Shift select the suprasternale joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

l_thelionControl:
*Create a joint curve control called l_thelionControl as instructed 
in Additional Instructions
*Shift select the l_thelion joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

r_thelionControl:
*Create a joint curve control called r_thelionControl as instructed 
in Additional Instructions
*Shift select the r_thelion joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

l_tragionControl:
*Create a joint curve control called l_tragionControl as instructed 
in Additional Instructions
*Shift select the l_tragion joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

r_tragionControl:
*Create a joint curve control called r_tragionControl as instructed 
in Additional Instructions
*Shift select the r_tragion joint
*Use matchPositionTool
*Go into component mode and select all vertices
*Move them away from the skin,in order to make the control accessible
*Go back to object mode and use FreezeTransformations

Now create a new joint and call it FeaturePointsRoot and snap it to the HumanoidRoot 
joint.Time to bind.



FeaturePointsLegs:
*Select the FeaturePointsLegs mesh and shift select the FeaturePointsRoot joint
*Smooth bind with the same settings as the original Ryan's bindings
*Select the l_gluteus_maximus,r_gluteus_maximus,l_rectus_femoris,r_rectus_femoris 
,l_trochanterion,r_trochanterion,l_biceps_femoris,r_biceps_femoris,crotch,
l_gastrocnemius  and r_gastrocnemius joints
*Shift select the FeaturePointsLegs mesh
*Go to Skin->Edit Smooth Skin->Add Influence[]
*Check Lock Weights and uncheck Use Geometry,everything else as is,and click on 
Add

FeaturePointsAccessories:
*Select the FeaturePointsAccessories mesh and shift select the 
FeaturePointsRoot joint
*Smooth bind with the same settings as the original Ryan's bindings
*Select the  l_gluteus_maximus,r_gluteus_maximus,_rectus_femoris,r_rectus_femoris 
,l_trochanterion and r_trochanterion joints
*Shift select the FeaturePointsAccessories mesh
*Go to Skin->Edit Smooth Skin->Add Influence[]
*Check Lock Weights and uncheck Use Geometry,everything else as is,and click on 
Add

FeaturePointsLeft_arm:
*Select the FeaturePointsLeft_arm mesh and shift select the 
FeaturePointsRoot joint
*Smooth bind with the same settings as the original Ryan's bindings
*Select the  l_acromion,l_axilla_ant,l_biceps_brachii and l_triceps_brachii joints
*Shift select the FeaturePointsLeft_arm mesh
*Go to Skin->Edit Smooth Skin->Add Influence[]
*Check Lock Weights and uncheck Use Geometry,everything else as is,and click on 
Add

FeaturePointsRight_arm:
*Select the FeaturePointsRight_arm mesh and shift select the 
FeaturePointsRoot joint
*Smooth bind with the same settings as the original Ryan's bindings
*Select the  r_acromion,r_axilla_ant,r_biceps_brachii and r_triceps_brachii joints
*Shift select the FeaturePointsRight_arm mesh
*Go to Skin->Edit Smooth Skin->Add Influence[]
*Check Lock Weights and uncheck Use Geometry,everything else as is,and click on 
Add

FeaturePointsTorso:
*Select the FeaturePointsTorso mesh and shift select the 
FeaturePointsRoot joint
*Smooth bind with the same settings as the original Ryan's bindings
*Select  the   cervicale,l_iliocristale,r_iliocristale,l_acromion,l_axilla_ant,l_clavicale  
r_acromion,r_axilla_ant,r_clavicale,navel,l_neck_base,r_neck_base,l_rib10,r_rib10,
substernale,suprasternale,l_thelion and r_thelion joints
*Shift select the FeaturePointsTorso mesh
*Go to Skin->Edit Smooth Skin->Add Influence[]



*Check Lock Weights and uncheck Use Geometry,everything else as is,and click on 
Add

FeaturePointsFace:
*Select the FeaturePointsFace mesh and shift select the 
FeaturePointsRoot joint
*Smooth bind with the same settings as the original Ryan's bindings
*Select the  cervicale,l_gonion,r_gonion,l_infraorbitale,r_infraorbitale,l_acromion
r_acromion,l_clavicale,r_clavicale,l_neck_base,r_neck_base,nuchale,sellion
supramenton,l_tragion and r_tragion joints
*Shift select the FeaturePointsFace mesh
*Go to Skin->Edit Smooth Skin->Add Influence[]
*Check Lock Weights and uncheck Use Geometry,everything else as is,and click on 
Add

Before continuing,we will move all feature points controls and meshes to the side to 
have  a  clear  and  accessible  control  panel  for  the  feature  points.Select  all  feature  points 
meshes,right  click  on  translateX  and  unlock  selected.Now  we  can  move  the  bound 
meshes.Select all meshes and all controls and move them on the X axis a fair ammount so 
that it doesn't get in the way.Select all controls and FreezeTransformations.It's time to apply 
the constraints.

cervicale:
*Select cervicaleControl
*Shift select the cervicale joint
*Parent constraint with offset

crotch:
*Select crotchControl
*Shift select the crotch joint
*Parent constraint with offset

l_gluteus_maximus:
*Select l_gluteus_maximusControl
*Shift select the l_gluteus_maximus joint
*Parent constraint with offset

r_gluteus_maximus:
*Select r_gluteus_maximusControl
*Shift select the r_gluteus_maximus joint
*Parent constraint with offset

l_gonion:
*Select l_gonionControl
*Shift select the l_gonion joint
*Parent constraint with offset

r_gonion:
*Select r_gonionControl
*Shift select the r_gonion joint
*Parent constraint with offset



l_iliocristale:
*Select l_iliocristaleControl
*Shift select the l_iliocristale joint
*Parent constraint with offset

r_iliocristale:
*Select r_iliocristaleControl
*Shift select the r_iliocristale joint
*Parent constraint with offset

l_infraorbitale:
*Select l_infraorbitaleControl
*Shift select the l_infraorbitale joint
*Parent constraint with offset

r_infraorbitale:
*Select r_infraorbitaleControl
*Shift select the r_infraorbitale joint
*Parent constraint with offset

l_acromion:
*Select l_acromionControl
*Shift select the l_acromion joint
*Parent constraint with offset

l_axilla_ant:
*Select l_axilla_antControl
*Shift select the l_axilla_ant joint
*Parent constraint with offset

l_biceps_brachii:
*Select l_biceps_brachiiControl
*Shift select the l_biceps_brachii joint
*Parent constraint with offset

l_triceps_brachii:
*Select l_triceps_brachiiControl
*Shift select the l_triceps_brachii joint
*Parent constraint with offset

l_clavicale:
*Select l_clavicaleControl
*Shift select the l_clavicale joint
*Parent constraint with offset

l_biceps_femoris:
*Select l_biceps_femorisControl
*Shift select the l_biceps_femoris joint
*Parent constraint with offset



l_rectus_femoris:
*Select l_rectus_femorisControl
*Shift select the l_rectus_femoris joint
*Parent constraint with offset

l_gastrocnemius:
*Select l_gastrocnemiusControl
*Shift select the l_gastrocnemius joint
*Parent constraint with offset

l_trochanterion:
*Select l_trochanterionControl
*Shift select the l_trochanterion joint
*Parent constraint with offset

navel:
*Select navelControl
*Shift select the navel joint
*Parent constraint with offset

l_neck_base:
*Select l_neck_baseControl
*Shift select the l_neck_base joint
*Parent constraint with offset

r_neck_base:
*Select r_neck_baseControl
*Shift select the r_neck_base joint
*Parent constraint with offset

nuchale:
*Select nuchaleControl
*Shift select the nuchale joint
*Parent constraint with offset

r_acromion:
*Select r_acromionControl
*Shift select the r_acromion joint
*Parent constraint with offset

r_axilla_ant:
*Select r_axilla_antControl
*Shift select the r_axilla_ant joint
*Parent constraint with offset

r_biceps_brachii:
*Select r_biceps_brachiiControl
*Shift select the r_biceps_brachii joint
*Parent constraint with offset

r_triceps_brachii:



*Select r_triceps_brachiiControl
*Shift select the r_triceps_brachii joint
*Parent constraint with offset

r_clavicale:
*Select r_clavicaleControl
*Shift select the r_clavicale joint
*Parent constraint with offset

r_biceps_femoris:
*Select r_biceps_femorisControl
*Shift select the r_biceps_femoris joint
*Parent constraint with offset

r_rectus_femoris:
*Select r_rectus_femorisControl
*Shift select the r_rectus_femoris joint
*Parent constraint with offset

r_gastrocnemius:
*Select r_gastrocnemiusControl
*Shift select the r_gastrocnemius joint
*Parent constraint with offset

r_trochanterion:
*Select r_trochanterionControl
*Shift select the r_trochanterion joint
*Parent constraint with offset

l_rib10:
*Select l_rib10Control
*Shift select the l_rib10 joint
*Parent constraint with offset

r_rib10:
*Select r_rib10Control
*Shift select the r_rib10 joint
*Parent constraint with offset

sellion:
*Select sellionControl
*Shift select the sellion joint
*Parent constraint with offset

substernale:
*Select substernaleControl
*Shift select the substernale joint
*Parent constraint with offset

supramenton:
*Select supramentonControl



*Shift select the supramenton joint
*Parent constraint with offset

suprasternale:
*Select suprasternaleControl
*Shift select the suprasternale joint
*Parent constraint with offset

l_thelion:
*Select l_thelionControl
*Shift select the l_thelion joint
*Parent constraint with offset

r_thelion:
*Select r_thelionControl
*Shift select the r_thelion joint
*Parent constraint with offset

l_tragion:
*Select l_tragionControl
*Shift select the l_tragion joint
*Parent constraint with offset

r_tragion:
*Select r_tragionControl
*Shift select the r_tragion joint
*Parent constraint with offset

At this point you can do the skinning,just like you did on the original Ryan.The joints 
we added as influence objects will be locked so unlock them first and then start painting their  
weights.When you're done you can save their weight maps for backup.

As  a  final  step  let's  create  a  structure  for  the  blendshapes  and  store  them under 
Ryan_Anatomy.

*Select all feature points joints and the FeaturePointsRoot joint
*Group them(Ctrl+G)
*Rename the group to FeaturePointsJointsGRP
*Select all feature points controls
*Group them and rename the group to FeaturePointsControlsGRP
*Select all feature points meshes,FeaturePointsJointsGRP and 
FeaturePointsControlsGRP
*Group them and rename the group to FeaturePointsGRP
*Shift select Ryan_Anatomy
*Parent by pressing the P key.



Appendix K:Settings for Export in Maya

To export,we need to export everything in case we miss something,so we go to File-
>ExportAll[].

We wll get a popup browser window.Select OpenCOLLADA exporter in File type.
Now,a list of all the checkboxes we want checked(the rest must be unchecked):
*Default file extensions
*Preserve references
*Cgfx file references
*Static curve removal
*Polygon Meshes
*Joints and skin
*Animations
*Texture coordinates
*Normals
*Normals per vertex
*Vertex colors
*Vertex colors per vertex
*Export references
*Dereference
*YFov

An easy way to set  it  up  is  to  reset  the  settings  from Edit->Reset  Settings,select 
OpenCOLLADA export in File Type and uncheck Cameras and Lights.

Then click Export All,select the directory of your preference,enter a filename(without 
the .dae extension as it will be automatically given) and Export All.
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